Datasmith conversion Problem

Recently I have a huge conversion problem with Datasmith. In 3DS Max I export the following data:

The directory into which the data is converted is not empty and the converted files also have a different byte size. But if I want to import them into Unreal I get the following error messages.

Not a single file is imported.
What’s the problem? Can somebody help me? Does anyone know the answer?
Thank you very much in advance.

Hi cgArchitekt

With the .udatasmith file you import, is it located in a Windows folder that also includes the _Assets folder? And in that _Assets folder, are there the .udsmesh files?

Hi Stephen,

yes, that’s exactly what it is.

But I’ve made several other conversions before and exported them into the same export folder. And I’ve a previous version of the same 3D models (with some mistakes and yet not ready and perfect) and the datasmith conversion worked perfect. Now I’ve updatetd and finalized the models and the conversion does not work again. I’m completely at a loss.

Dear Stephen,

I think I’ve solved the problem and found the bug.
Datasmith doesn’t seem to like umlauts (ä, ö, ü). If I use a file name with an umlaut for the conversion, then the problem occurs. If I don’t use an umlaut, it works and there is no more error message.

Good discovery! Would you please report it as a bug here?

Thank you!

Fixed in 4.20

very good - I’ll try it out as soon as possible ;):smiley: