DataSmith / CineWare crashes (but only in architecture template)

Hello people!

I am a 3D Artist usualy working in Cinema4D.
We have a client who wants to have real time archviz for a kind of a showroom.

So, I ran into a big problem und wasted a whole week now to figure it out but with no solution.
We need to have some animated Blinds and other animated Sunprotection products.
So I made a building in C4D and imported it via datasmith no problem. I made sceen look “good” with trees etc. But now if I want to import the animated blinds from C4D via datasmith and I check the animation cache, everything crashes , even the youtube video that runs on the second screen freezes.

Even if I use a fresh blank architecture template it crashed. it doesn’t matter how simple the animation is. The last thing I tried was just a few slabs in a cloner and even that crashed.

BUT now comes the weird part, just out of curiosity I tried a ordinary blank game template and everything is importing fine. Even if try to import the blinds for all windows at once it works.

So whats the difference between the “game” and the “archviz” templates?

I really hope someone can help me out. I am losing my last nerve here :sweat_smile:

Thanks!

Could it be hardware raytracing? Try disabling that in the project before importing. What GPU do you have?

Hello

I’ve got a nvidia RTX 4080 (it is a laptop though).
Where would I deactivate that ? Shouldn’t that be active in every template ?

For people that may have the same issue as I have. It was/is the “hardware raytracing”

If you disable that the datasmith import doesn’t crash anymore.

BUT even after importing all your C4D files you cannot turn hardware raytracing on again.

It will ask you to restart the engine and after that everything will crash at the start again.

I had to change an .ini file to even get back into my project.

I don’t know this seems kind of a bug. I don’t really understand why you can’t find anything about it on google.

Sorry I missed your last message. Some templates do not have HWRT enabled by default, but the architecture ones definitely do.

What version of Unreal Engine are you using? Are you able to share a test export with me?