Download

Datasmith Cinema 4d plug-in not working Nvidia RTX caustics branch

Hi there,

I have the Nvidia NvRTX caustics branch build but the Datasmith Plugin for Cinema 4d doesn’t work.

When I click the Datasmith button in the top ribbon it opens up the file explorer but only gives 3 file extension options so my C4d files don’t show up. On the regular install of unreal 4.25 with Datasmith there are around 20 file extension options.

when I completed the build with VisualStudio 2017 there weren’t any errors or warnings.

does anyone know how to fix this, will it work if I take the plugin from a working version of unreal and patch it then rebuild my NvRTX version?

Thanks in advance

Jonny

Same problem as well, did you manage to solve it?

Have you made sure that the C4D Datasmith plugin was enabled ?

Cheers,
Antoine

It definitely is. I also tried rebuilding from the official source like OP suggested with same result.

Update: RTX DLSS 4.25 Branch has the same issue.

Solution found!

First you have to install the marketplace version of the engine. Copy the “DatasmithC4DImporter” folder (inside Engine\Plugins\Enterprise) from the marketplace versions folder into the compiled source builds folder.

Then you have to trick the editor into thinking the plugin that you copied over were built from the same machine, to do this do a search for .modules files. Open up each of these and replace the “BuildID” with your own BuildID that was generated for the source build.

You can find your BuildID by opening another .modules file from anywhere in the “Engine” folder inside your source build (just doing another .modules search should suffice). BuildID’s from a source build will be formatted differently but don’t let that confuse you. Everything should work fine after this.

Although I haven’t tested every source build it should in theory work in any and not just RTX branches.

Epic thanks Kuroderuta, that works a treat!

Do you have any idea about applying the RTXGI Plugin, I’ve been following a video where it shows you how to patch it via a command prompt but I get errors, feel like I’m missing a step as I’ve seen some places mention cmake, I’m not a coder or anything so getting a little stuck.

if you have any ideas?

Thanks again
Jonny

You don’t need the plugin if you’re using the caustics branch, a RTXGI is already implemented there. Personally I haven’t even received a response to my submission yet so I couldn’t play with the plugin yet.

Hi, Can I get some help with the NvRTX branch.
I downloaded and compiled the latest version but caustics are not showing up and when I try to launch the demo scenes said I am missing the DLSS plugin :frowning: