Data Table issue

Hi everyone. I have a problem with a data comparison. But playing in the editor everything works. If I launch or pack the values are returned different. I have an array (“Confronti”) with two indexes, the content is Text. In the table, using the correct break of the structure ( is also the Text) it must see if the two Text are equal with a branch. Why does it work in the editor and not launched? In the photos you can see the purple writing. In the editor the Text is found and therefore it is True. In the launch Instead all False, but the data is always the same.



Hello Miki,

Is the pink lines the data from the data table? Have you tried printing out what values “Contronti” has? Maybe it’s not getting updated propely on a Launched game, thus ending up empty or some sort…


Hi, thanks for the reply. Yes pink is the data and purple is the condition if the string is found. Yes, for the “Confronti” array I also tried to insert them manually and those are printed. I did a project migration a month ago, could this be the cause?

I solved it like this

i think two loops together didn’t work. Thanks anyway.