Download

Dat stupid AI

Hlp1.jpgHlp2.jpg

Hi.

My AI has some problems knowing how to move around.
In the first picture are the AI seen when set to moving towards a spawn point with the “Move to location” node.
But they doesnt seem to react to the break in the navmesh, and just towards he point directly, which means they just run their heads towards the wall, and completely disregard the door.
(They move into the room through the door, but only because there is a move to node just outside, otherwise they run against the wall when moving in again.

Any idea on why this occurs?
It has worked perfectly in other games i made.

I think you told AI to do exactly this. They may be dumb as rock but they are obedient and do whatever you tell them to do.
All i can see from pictures it is that for sure you have navmesh working.

If it were an isolated incident, i would agree with you.
But all of them, do it with everything, choosing to take the direct path, and not navigating around anything.

c1e79e881f0e98a41d7e9274ee35e3f4efdcd327.jpeg

This is an example of them leaving the world (Which is what they are attempting at the image)
The node they are trying to reach is located 580 units away from the wall on the otside, within the navmesh region.
There only exist one node with the matching ENUM.

So unless something has changed with this node, or with the basic setup of movement behavior from 4.10 to 4.11, i am most certain i haven’t asked them to walk into the wall, since this setup has worked in earlier games i have created.
But ofc, i might be wrong, and any ideas are muce appreciated.

use VISUAL logger and game debugger.

Everything looks fine in this graph. So you need to find culprit, step by step.
Easiest node to check is removing that additional random point.
There may be situation when random point adds offset exaactly towards wall, then their add up that 100 to acceptable radius and find out that destination is on wrong side of wall.
But i am guessing, you need to debug it all. And visual debugger making nice small arrows is very helpful for such stuff.

Any tutorials on visual logger from ground and up? As i haven’t done anything like this before, and as of now doesn’t even know how to activate it.

Problem solved. Forgot to update the navmesh in runtime, as a storefront is spawned upon opening and therefore isnt recognised by the navmesh, but is still blocking the actor… *Double Facepalm.