Custom Time Dilation for Physics Actors

Hi there. As far as I can tell, Custom Time Dilation currently has no effect on the physics processing for actors in the world. Gravity, collisions, added force, etc all appear to be slave to the world DeltaTime. Is there any known way around this?

Thanks

Hello JManso,

CustomTimeDilation it is actor’s option. It allows each actor to run at a different time speed and it has no affect on physics, because there is no way to manipulate with simulation for one physics body. But you can try to use TimeDilation from WorldSettings. It affects on all actors tick + physics simulation.

GetWorldSettings()->TimeDilation = 0.1;

Or

Console command: slomo 0.1

Best regards,
Gleb

Yeah, I’m aware of the world dilation setting, but unfortunately it won’t achieve what I’m looking for. Thanks for the response.

Hi JManso,

I think you need to check the volumes (especially physics volume). It can solve part of your problem. Also you can create your own volume and apply some special options you want to actors in there.

Here are some threads that can be helpful as well,
https://docs.unrealengine.com/latest/INT/Engine/Actors/Volumes/index.html

Best regards,
Gleb

Is ther any workaround now in 4.18?