Download

Custom Player Controller not Registering Inputs

Hello all, this is a duplicate of this question I asked on UE4 AnswerHub, I hadn’t gotten an answer in about a month so I would like to ask the question here:

I’m trying to use and understand the basics of UE4 development, but have run into a problem creating a custom PlayerController. I’ve made a blueprint CustomerController which inherits from Player Controller, here is the event graph:

What I expect to happen with the controller is that, when I click “Play” and “Possess”, a message will be printed when I press A or D. Naively I think I’ve set all of the settings right, here is the Blueprints dropdown:

Yet no output occurs when I try to “Play>Possess”, no output occurs when pressing those keys. I’ve tried “Enable Input” on “BeginPlay”, but unsurprisingly that didn’t work; I think its meant to apply an actor to a PlayerController, not a PlayerController to itself.

Any advice on how to get this to work and/or misconceptions I have made would be appreciated.

Thanks!

I’ve tried to replicate this but I can’t produce the same error and after pressing play and right clicking in the viewport, I’ve got A and D being printed to the screen once I press those buttons.

When you press play are you able to look left/right with the mouse and move forward/backwards with W and S? If not, try right clicking in the viewport (assuming you’re using the ‘Selected Viewport’ option and this is a fresh blank project template).

I’m just wondering if maybe your A/D events are being overridden by another function?