Custom player controller ignoring input

For whatever reason the controller that I created is ignoring every input. SetupinputComponent is being called, In the gamemode the controller and pawn is set. I don’t know what to do anymore.


Hi i don’t see in your SetupInputComponent(),that you are calling Super::SetupInputComponent().Try it should help!

Sorry doesnt see it. Use AutoPosses player select to Player 0 and remove AI Controller to base

Hey ! Did you try this ?

AutoPossessPlayer = EAutoReceiveInput::Player0;

For getting the input you need to tell unreal engine to enable the input for the blueprint

it’s there, right under GEngine.

didn’t do it either

where would do that? in the constructor of the controller?

not working either

ok figure it out. in the PlayerTick I changed “Super::Tick(DeltaTime);” to “Super::PlayerTick(DeltaTime);” and that fixed it. I originally had it as Tick because unreal was complaingn to me that PlayerTick is not right. Guess it now likes PlayerTick.

1 Like

Inside your pawn construct