Custom Pawn Collision not working

Hello folks!

I hope someone can help me out. I’ve started setting up a small game prototype, namely a Pong game. However I’ve run into a pretty weird issue. I’ve tried setting up the player’s cuboid or collumn or however you want to call it. In that way the root of the scene is a capsule, which is obviously wrong for this kind of player character. Of course, this cannot be modified or deleted, because it’s inherited from the basic character C++ class.

So what I did is I’ve set up a new pawn blueprint, modified the controls and movement to work properly. However, when I try to set up the collision, no matter what I try it just won’t work. I’ve tried having a mesh as the scene root, with proper collisions set up, I’ve tried adding a box collision as the child of this mesh, still not working. I’ve tried setting up a box collision for scene root, and then the mesh for the child of this component, still not working. I’ve tried setting up the different collisions, for the components the same way as they are set up in a basic player character blueprint, but nothing seems to work. If I turn on simulate physics, it will do collide with objects, but that way the floating is gone, and the whole movement is ruined.

Anyone has an idea how to fix this, or any kind of workaround? What I’ve been thinking about is using the scale of the capsule in a basic character blueprint to somewhat include the mesh I want, but obviously that’s not perfect, and will give me tons of problems later. Please help out if you can, screenshots are appreciated of a proper set up.

Thank you!

Bumping, maybe someone can help.

Having the same issue. I’ve tested tons of combinations of checkboxes and pawn’s component tree configurations. Still have no collision. Guys, anybody, please help!

The best I could do is turn on simulate physics, and remove the gravity. This works for my game, tho I constantly have to check if my object is colliding hard enough to change it’s rotation, and if it does I have to revert it all back.

Yeah, seems turning physical simulation on is the only workaround for now

Finally, I found a reason why my custom pawn didn’t collide! I simply didn’t check Sweep checkbox of AddActorWorldOffset node in movement logic graph :slight_smile:

Looks nice. I’ll take a look at it as well, however I was using AddMovementInput with a direction vector, not a WorldOffset, so might not work for me. Will test it later!

I also use AddMovementInput node which just set the movement direction of pawn when user input occurs. And then on Tick event ConsumeMovementInputVector node is executed, then final movement vector is built and passed to AddActorWorldOffset node.

In this case, we got our answer!