Custom mousecursor shows as black square?

So I’ve set up my blueprint all fine and dandy but the mouse cursor I’m trying to us shows up as a black square. The image I’m using is a 64x64 png format. Here is a shot of the HUD Blueprint. The name of the material I’m using is “mouse_default_Mat”

Hey KMP,

Can you post a screenshot of your material setup?



Also forgot that my alpha channel didn’t go through but I know how to fix that. Here it is…

Hey KMP, did you find a solution for this? I’m encountered the same obstacle.
I have my transparency working but still only see the black silhouette of my cursor (should be blue).

Does anyone know how to exclude textures from global lighting and have them always maintain the same exposure to the player? Have a feeling this is the problem.

No I have not yet. I tried a few different tutorials I found on youtube but still got the same result. Attached is how my cursor should look.


Hey KMP, I’m guessing you followed this video - Blueprints - How to Create a Custom Cursor - Unreal Engine 4 - YouTube

Which I did too, but he never explains how to create the material first, nor did he do a follow up on how to get your cursor to change depending on what it’s hovering over - something I really need.

What I can help you with is the material’s transparency. You should change your material blend mode to ‘masked’ then link the textures transparency node to the ‘opacity mask’ node in the material inputs.

Here’s an image to illustrate, hope it helps.
Of course, it’ll still be black. Ignore my crappy blue cursor, it’s just a test.

Hey Whats Up Everyone,

The way I made my Material is by setting the Blend Mode to Translucent. Then plug in your Alpha to the Opacity param. Remember when using Opacity / Alpha, white value reveals, black value hides. I’ve linked my setup used in the tutorial. This is also similar to how it is done in the content examples.

I plan to make a Tutorial on how to change your cursor when hovering over actors. Working on a UI at this time, so its in the plan.

I hope this helps.


This only works if the cursor is white. Mine is colored and it does not work as the blacks get hidden. This is not the correct way at all.

I put the alpha onto Opacity (the texture has an opacity layer), and while it looks fine in the materialview, when ingame it is just black. Why’s this?

I just solved this issue. I have a transparent PNG and it wasn’t working. The problem was with the material. What worked was setting it to translucent, unlit and wiring the texture to Emissive Color and the Alpha to Opacity.

I am using Draw Material Simple. Not sure why the texture shows as just a red square, it’s a red cross hair 32x32 texture and it works now.

After I do this, the cursor no longer appears black, but does not appear at all. It looks fine in the material view.

I know this is pretty late it’s year 2016 right now and the problem was from 2014. But, If you haven’t fixed it yet, but I believe you have fixed it already. Anyways, I will just post my solution.