Custom icon doesn't work for package

I see this question has been asked a couple times, but none of the questions included a clear answer or only mentioned what caused the issue and not how to fix it.

I’ve created an .ICO file for my game which contains 10 different icon sizes. When I go to project settings and load the icon file it loads fine. But when I create a package of the project the executable that get’s created still shows the black default Unreal icon. I cannot seem to find out on how to solve this. The icon file is located within the Source\projectname\Resources\Windows folder and all settings seem to be set properly.
Some people mention I need to press a “set as default” button inside the project settings window. This button is non existent on my version (4.5.1). It only shows a line saying “These settings are saved in DefaultGame.ini, which is currently writable.”.

Can anyone tell me how to fix this? Bear in mind that I’m not an experienced UE4 user so I cannot understand all technical terms yet.

Howdy Mr Robville,

Thank you for reporting this issue. I have placed a similar issue to this in the our bud database previously and How just looked into the report. There is a fix in place that is to be released when 4.6 is released. If you come across this issue once 4.6 has been released, please feel free to reopen this issue so that i may further investigate.

Thanks and have a great day!

Thanks a lot for your response! I shall await for V 4.6. Looking forward to it.