Custom Hardware Cursor does odd thing

I set a custom hardware cursor (I tried this in the project settings and blueprints) and it will only show if I am in a windowed mode and move the mouse out of the window and back in. Why doesn’t it show when it starts in fullscreen mode? Any ideas on how to solve this?

I’m seeing the same behavior. Haven’t found a good solution yet.

Having the exact same problem - it works fine in PIE but a standalone or packaged export will NOT show the custom hardware cursor until I alt-tab (or move out of window and back in assuming no mouse capture).

  • EDIT * So I believe I fixed this issue. Make sure you turn OFF Capture in the Project Settings -> User Interface. However make sure to then have Always Lock on for the viewport. It seems as if the Capture was interfering with the hardware cursor.

You can simulate a similar thing in the PIE settings by telling it to always give game mouse control, if you do the hardware cursor won’t work in PIE either.