Download

Custom Font has no Kerning

Hello,

I’m experiencing an issue where a custom font is not displaying any of the kerning that is configured in the .TTF. Instead, all glyph pairs are equally spaced with no exceptions.

I created the font in Glyphs. I’ve used it in Photoshop where it displays kerning pairs properly. I’ve also tried exporting and importing the font as a .OTF.

Other .TTFs I’ve downloaded and imported display correct kerning in Unreal.

Any advice would be appreciated.

Cheers.

I solved the issue with help from the Glyphs community.

Apparently Unreal still looks for an older kerning table in the .TTF.

To make my custom font’s kerning work in Unreal, I did the following.

  • Open Font Info.
  • Add a custom parameter.
  • Type “Write Kern Table” as the name of the property.
  • Check the checkbox that appears.
  • Export the font as a .TTF.
  • Import the font into Unreal.

Cheers.

Any idea how to do the same with font forge on windows, This happens with a downloaded font - “Blocktastic”
Please help!

When you generate your font in font forge there’s an Options button. In that menu there’s an option for " old style ‘kern’ " . This should do the trick