Download

Custom Collsion is not imported with the mesh

I have this static mesh:
63d2bfac826003747269d6b9f262cf2e915fcbe0.png

The collision boxes are named with the UCX_ prefix

When I import it to UE4 the collisions wont be imported. How to fix this?

Hi Croatoan,

It needs to be UCX_prefix rather than CBX_prefix.

“UCX_” will create the collision mesh when you import it. :slight_smile:

Tim

I did name them using the UCX prefix, I dont know why I wrote I used CBX, i will correct it. Anyways I am using the UCX_ prefix and the collision is not imported

Just for clarification I’m posting the steps here to create a collision file in a 3D software and import it into UE4.

  1. Create mesh (in this example named “Box”)
  2. Create a mesh that will be used as collision
  3. name that mesh UCX_(name of mesh) (in this example “UCX_Box”)
  4. select the objects you want to export to FBX
  5. Import and use default settings.
  6. Open mesh in editor and click the Collision tab to view the collision mesh.

https://www.dropbox.com/s/inxopwo5c6fgyyj/BoxCollisionTest.zip

I’ve included the simple files I made in the zip above. There is an FBX and the Max file saved as a 2010 version in the event you or someone else does not have 2013.

You can also find more information on Collision FBX workflow here.

If you’re still having trouble with your asset feel free to upload here if you want me to take a look.

Thank you!

Tim

I personally would recommend to disable the “one convex hull per…” in the import settings, because otherwise you wont get a very precise collision :slight_smile:

Here is a collision tutorial: http://www.youtube.com/watch?v=TTsAYpqHU-c It’s for blender, but it works the same in 3ds max and maya

Thank you for the very detailed answer. I didn’t know i had to select the objects in 3dsmax before exporting, it solved the problem.

Also thank you, fighter, for your suggestion

Glad you got it working!

I believe you can export without selecting in Max. There are two options for export, Export and Export Selected. I’ve just always been in the habit of using the latter even if those are the only objects in my scene. I feel like I have more control that way! :slight_smile:

If you have any other questions feel free to ask!

Tim