Custom Character not working


Today, I was programming a custom character and faced some issues. First, i programmed my custom game mode and it works without any error after that i made a custom character code which looks like this:



and initialized it in my custom game mode like this:

but for some reason it doesn’t work, i get no errors but nothing changes.

I am sure i added the axis definitions in engine and i am sure the default game mode is set to my custom game mode. I am using the 4.3.1 version.

Can someone tell me why this happens and how to fix it?

Any help will be appreaciated,

**Hey ZeroIP!
For starters, a few things to debug!

First of all, make sure that for your MoveX/MoveY, the directional vector isn’t coming back as some obscenely small value.

In each function use:

if(GEngine) GEngine->AddOnScreenDebugMessage(-1, 0.001f, FColor::Red, Direction.ToString());

You’ll make sure it’s then actually being called, and the value is usable.

Secondly, check that the bindAxis names are matching in both the editor and script.
And lastly, make sure in your constructor that ‘bUseControllYaw’ is true. (Same for Pitch and Roll).

And that should be it working! (Also make sure you are using your custom char in your GameMode).
(I have forgotten this so many times!!!) >:(

I hope this helps!


Try changing your Solution Configuration in the dropdown at the top of the screen. I keep mine on Development Editor unless I actually want to debug a build.

Thanks for the help, but… nothing seems to change, i tried everything you said and recognized that the MoveX/MoveY aren’t even being called, i am pretty sure the editor axis mapping and the code matches, i need to fix this urgently. I am using 4.4.0 looking forward to getting some more help!

Just verifying you saw my post and tried that as well?

Yes, i did. It was already set to Development Editor, i tried debug too. Nothing seems to change.

Try closing the editor and hitting F5, and launching from that editor.

Nope, no changes i am really confused right now, it seems to work for everyone but me…

Will someone be available to help me with TeamViewer or something? I didn’t manage to solve this.

Hey ZeroIP!

I’d be up for helping out as best I can on TeamV. :smiley:
Just let me know when you are ready xD