Download

Curved track gets lumpy in UE when driven on it (from Maya)

Hi all,

I have created a curved track using a loft surface in Maya. When I export it as an FBX file ane import into Unreal and attempt to drive on it I am getting a “lumpy” driving experience, where as I drive I am going up and down in the surface - like the collision is not following the geometry.
48948b37652e3392c0659a1cda29d9c946f3eed9.jpeg

How do I create a curved track (going to be an elevated road) out of Maya and have the collision in UE match the exact geometry?

Is this something where I need to loft the object differently? What should I be using for collision?

Thank you!

I don’t have maya so I can’t say, but instead of trying that you could just use ‘splines’ in ue4 and use a mesh of your choice ( sections) to attack to them.

Blueprints for them are simple to follow, youtube has a few no biggie.

https://www.youtube.com/watch?v=wR0fH6O9jD8&t=284s

Hope that helps.

Isn’t it best practice to do asset creation in a dedicated tool, and then export over to UE? I am trying to mimic best practice workflow.

Thanks for the link, I will take a look - anyone else with Maya specific experience? How about concerning the collision states?

I have been experimenting with curved tracks, generated in Blender and exported to fbx files, and I see something very similar. My solution was simply to give the mesh a higher poly count.

I don’t think there’s anything funny with collision going on, because my meshes have no extra simplified collision mesh or anything like that. I’m pretty sure the engine is just using the raw mesh data for colliding the car along the track.

How many triangles are in your meshes? Are you sure it’s high enough? Have you tried simply adding more sub-divisions of the curve in maya, and thus ending up with more tris in the final asset? I would give that a shot and see what your results are. (From the picture you posted, it seems that there aren’t a whole lot of triangles in your mesh.)

Also, having some kind of smoothing on the camera can make a difference. When the camera shakes, it’s of course really noticeable. But when just the car shakes (and the camera stays smooth), then that is much more acceptable visually. Experimenting with the smoothing on the SpringArm (the component I’m using in my car currently) or some other form of smoothing could be worthwhile, if you’re not doing that already.

Can you post a video somewhere of the “lumpiness”? I could have a look and see if it’s similar to what I see.

Please keep in mind that I’m new to Unreal, so I may be doing it wrong. I’d love to know if there’s a better way.

Here are some screenshots of what I’m talking about.

The first is of a 90-degree turn, with a twist in it so the outer edge rises up. (So the track is totally flat at the start, but has a bank of 30 degree or so at the end.) Dividing this into 16 sub-divisions, you can see there is a distinct bumpiness to the track. The line down the middle, which comes from the material used, should be a nice curve. But it’s not, you can see how it goes up and down. It might be a bit hard to see, but it’s there if you look for a bit, and driving on this produces bumpiness in game. This pic does not show the full 90-degree turn because I placed the camera to best show the effect, but the actual model does go through 90 degrees.

16-division-quarter-curve.jpg

The next shot is the same thing, but with 256 sub-divisions, along the length, and 4 across the breadth. (Way more triangles.) Driving on this is very smooth, even without any camera smoothing. (I disabled the springarm component so the camera was fixed rigidly to the car.)

256-division-quarter-curve.jpg

Finally, here is a wireframe shot of each, just to show the poly difference. You can see the second has a lot more polys.

d3a23e1ed1a4ee65ceaacf1dc1fdc4b15b370aea.png