cursor does not appear when widget is on screen

I’m trying to implement a ‘‘talent tree’’ widget. When I press the ‘‘C’’ key my widget is added to the viewport and can be toggled on/off but my cursor is not appearing. Anyone could help me on how to make the cursor appear over the widget?

Show cursor is a variable (boolean) of your player controller. You have to manually set this to true if you want it to be seen. Simply adding a widget doesn’t do it by itself.

You can use “Set Input Mode Game/UI” which gives you a checkbox on whether or not the mouse should be shown or get a reference to your player controller and set “Show Cursor” from there.



When you add/remove widget, you should enable/disable mouse cursor.

1 Like

We had a similar problem. Turns out that the root widget of a canvas panel is default to ‘no cursor’. You have to change that. I think the idea is that one might pop a panel but still want mouse clicks on the 3D background word. (like the Unreal Editor does). So all that transparent space expects to have some kind of 3D cursor, not the 2D menu cursor. (In my humble opinion the default should be set to true.) The previous answer is also valid. You DO have to set the cursor on etc. when you popup the overlay.

1 Like