Download

Culling problem : Landscape issue with not registering my spacial position

Something is amiss with my game. It was all going pretty well, and i’ve even tried upgrading to 4.11 preview to see if this problem goes away, but for some reason when i’m on the ground in my game it seems to have a hard time understanding where i am.

If i jump. it registers and objects, trees, rocks go on. I’ve played with the cull distance settings. I’ve played with the bounding object making it larger, and the max draw distance. None of these are the problem though, as it really seems to register only when i jump off the ground.

argh. so i’m going to do a test and see what happens if i replace my landscape with a piece of geometry and even make my landscape out of geom in Maya… however if anyone has any insights or experience with this, please let me know. I thought it was my graphics card at first, but the jump seems to point to something with the landscape getting int he way of telling the engine the position of the player, thus randomly turning things off.

Just to follow this up. I of course couldn’t export the geometry from Maya without creating a very complex collider to go with it.

Instead, at least just as a test, I started laying down colliders to walk on, on my landscape. This is working, it’s not a great solution as i would have to do this everywhere, but again points at the landscape as being a problem and I’m not exactly sure why. Again, while walking on the landscape the game is not sure where I am, and thus starts culling things randomly, flashing on and off. If I jumped things would go on, and on placed colliders it seems to work.

I still have to find a better solution but it points in the right direction. I built landscape in another level from the same maps, and that is not doing this at all. It is a far less complex scene, but i’m going to look at other variables that could be the difference in one working and the other not… my suspect right now is scale, but I’m not sure about that.

scale is likely the culprit here. My scale of the object is 200 200 64. In the other scene it is merely 24 24 64 with no problems. So I tried to resample at higher rates my landscape but it quickly became too heavy to sustain. The landscapes are the biggest hog to my game, it stutters and comes to a halt easily. I don’t understand how people can make extensive games with these kinds of restrictions. I don’t see it turning parts off of the landscape, as i seem to remember Unity doing as things got further away. In Unity it would also tesselate the further polygons less, the further away they got.

This is really bumming me out. I want my levels to be expansive, like a real environment not just hallways leading to rooms, but landscapes seem to get in the way often.