Cull Distance Not Working?

I´m trying to cull some actors tress in my level, but the Cull Distance volume seems not be working

see picture:

the Tree is not foliage, it is a movable actor

Thanks for any help!

Hey FilipeTessaro,

I just entered a bug pertaining to this issue as the Cull Distance Volumes do not work within the Viewport, but will work as expected when Playing in Editor (Pressing Play).

I entered a bug to see if this is the expected behavior since the volumes calculate based on distance from the player camera, and since there is no active player in the world when working in just the viewport, no culling will occur. Nevertheless, the bug entered (UE-25079) is calling to question whether or not this is indeed the expected behavior, as I can see the benefits of being able to preview the Cull Distance Volume function within the editor without having to press play each time.

Edit: This seems to be directly related to the viewport camera because as soon as you add a camera actor at the set distance for an object to be culled out, it works as expected (even without having to press play).

Thanks for taking the time to report this issue, and let me know if you have further questions.

Cheers,

Andrew Hurley

It is working now, sorry
Indeed we need to play it to work, or change the viewport to: “Game View”

Thanks

Hi FilpeTessaro,

This is expected behavior for Cull Distance Volumes. While there isn’t a lot of documentation for this at the moment that goes into the technical details there is a page that covers the basics for setup and use here under the Cull Distance Volumes section.

The functionality of Cull Distance Volumes has not really changed since UE3/UDK so the page here should have some helpful information as well until we can get something more in the UE4 documentation.

Some limitations:

  • It does not work in Editor, only when you’re running the game.
  • It does not handle movable objects. Only those with their mobility set to Static and with the option for “Allow Cull Distance Volumes” enabled in their instance settings. This is on by default, though.

So for your issue here. The trees will not use cull distance volumes since they only handled objects that are set to Static.

As an alternative method for your meshes since you’re not using the Foliage tool you can select the Tree mesh and in the Details Panel you can set the Min Draw Distance and the Desired Max Draw Distance for your LOD0 under the Rendering category. This will only work in PIE or in-game and not while working in the editor though, but it will work for your movable object. The distance values are based on Unreal Units, which is set to centimeters by default.

I hope this helps and clears up the issue you were running into.

Tim

The distance culling doesnt work at all in UE 4.15, not even in content example project…Please fix this ridicolous bug