Cull distance in topdown (perspective) view setup


we are working on little techdemo project. Camera is from perspective view and I tried to setup cull distance volume by this tutorial:

and Volumes Reference | Unreal Engine Documentation

And it does not work and i dont know why.

When I open a FPS project and try it, it works fine. But not from perspective (3rd PS view).

Can anyone please help me to setup it correctly?

Thank you. ,

Hi ifranckie,

Cull Distance Volumes work the same with FPS, Third Person, or any other view types. The Cull distance is based on the distance from the camera to the mesh in question within the CDV.

When switching the perspective the mesh will cull based on the camera distance. These cannot be adjusted during your game though if you’re character is switching perspective.

There is a feature request in for this with UE-6322 to be able to adjust these settings during your game. However, feature requests are not guaranteed to be integrated.

Thank you!


Hi Tim,

Thank you for your answer!

No no, maybe i said it wrong way. I mean that I tried it for the first time in some other fps project and it is work well.

Then I tried to apply this feature in my other project where camera is like in this video:

And it does not work (in one setup nothing shows up and in other everything shows up).

What I want is that everything what is not in FOV of the topdown camera (or everything what is in some range from player) will not show up in the game, so level should be optimised. like this:

So is in UE4 some feature like “Occlusion Culling”?

Thank you.

There isn’t a visualization mode like the one you linked in the Unity video that I’m aware of for UE4, but this is similar to what UE4 does as well. Anything within view of the screen that is not being culled by other methods is not rendered. The engine does a good job of optimizing your scene automatically.

If you need to see what actors are being occluded you can use the console command r.VisualizeOccludedPrimitives 1 to enable this view. A green bounds box will appear around the occluded mesh.

This method is mentions in our Performance Guidelines here: Testing and Optimizing Your Content | Unreal Engine 5.1 Documentation

If you want to go the extra step you can use Cull Distance Volumes so that any mesh inside the volume is culled based on the size and distance you would like.

The last method allows you to select a static mesh in the viewport and in the details panel you can set the Min and Max Cull Distance. This will only work for the selected mesh. This does not require the use of the Cull Distance Volume to work.