Download

Cubiquity (v1) for Unreal Engine 4.14

Cubiquity

Cubiquity is originally made by David Williams and Matt Williams (About Us - Volumes Of Fun) for previous version of Unreal Engine 4. It was never released officially and it is still in development. The developers are making Cubiquity 2 and hopefully it will see daylight. I made a port for recent version Unreal Engine 4 so the community can profit from this marvelous piece of work.

I just made a quick port for UE4 4.14 but there is some problem that I need the community to help:

  • The plugin compiled successfully but the project crashes while loading shaders (on startup)

The independance brance of the plugin is here: GitHub - mhoangvslev/Cubiquity: Cubiquity is originally made by David Williams and Matt Williams (http://www.volumesoffun.com/about-us/) for previous version of Unreal Engine 4. It was never released officially and it is still in development. The developers are making Cubiquity 2 and hopefully it will see daylight. I made a port for recent version Unreal Engine 4 so the community can profit from this marvelous piece of work.

Just checked out the (About Us - Volumes Of Fun) link. Cool stuff. The concepts are quite intriguing.
Does it give a particular error message while loading shaders?
Is this new or has it been like this for some time now?
When was the last time it hasn’t had this problem, the last light build, and when was the last thing you edited before you notices it?

Here is exactly what I did:

  • Download current version of Cubiquity
  • Fixed some logical and compability issues
  • Successfully compiled the project
  • Launched the project and it crashes.

Here is a screenshot and log files:
Capture.PNG
UE4CC-Windows-37F5BB914CE79F1847B26B80DCBA2CE8_0000.zip (48 KB)

Is that the project in that zip file? If so I will take a look at it when I get home later tonight.
I’ve had similar problems like this but no crashes right away. I will see what I can do for you though, scavenging though the forums.

No but you can download the source code from Github, link above, and add it to your project.

Cool, I am still at work, but I will check it out as soon as I can. Hope I can help!

I fixed it and sent you a pull request.

I fixed it and sent you a pull request.

Thanks to andreybicalho, Cubiquity is now ready for use!
Feel free to download the plugin and use it to your liking!
I am getting through a complicated procedure to make Cubiquity available on Marketplace. Expect it soon!

Hey got a question - Does Cubiquity V1 support paged voxel volumes?

Just curious :slight_smile:

For now, it is just a simple port from old version of Unreal Engine 4 to the recent version. This means that we have all the existing features but nothing is added (yet).
I found an article that may answer your question:
http://www.volumesoffun.com/phpBB3/viewtopic.php?f=14&t=633

Hey all great work! Love this community… Can someone give me quick install guide? I have unzipped and put the folder into my Project’s Plugins folder. When launching the project, I crash. Thanks!

i cant get it to work it keeps crashing on me :frowning:

Hey Virtueel, try resolving the dependancies as discussed in this README

From the page:

There’s one or two files we need to edit before we start.
First is the Plugins/Cubiquity/Source/Cubiquity/Cubiquity.Build.cs file.
Edit the string in ThirdPartyPath to point to the place you unzipped the Cubiquity DLLs.
Secondly, edit Plugins/Cubiquity/Source/Cubiquity/Private/CubiquityColoredCubesVolume.cpp and CubiquityTerrainVolume.cpp.
Edit the string in the constructor of them to point to the place you unzipped the example VDB files.

The last thing you will need to do is put CubiquityColoredCubesVertexFactory.usf in UnrealEngine/Engine/Shaders in the main Unreal Engine folder (not in your project).

alright i got it not to crash and i have all the stuff, now how do i accualy open vdb files to edit maps? i’am very new to c++ but i do have programming knowledge from java so i know how coding syntax works and all variables and ****.

and i just realized the cubes are suppose to have colors, they have in a cubicle video :confused: so stuff is stll not working for me :stuck_out_tongue: is there another way of doing this with like vox files or qb files?

Good job man, it does compiles. Now time to use that thing!

Are the 2 blueprint files in Content/Cubiquity/ not supposed to be used? “CubiquityColoredCubes” and “CubiquityTerrain” are orphan classes that can’t be opened and fires this message: Blueprint could not be loaded because it derives from an invalid class. Check to make sure the parent class for this blueprint hasn’t been removed!
Did I do something wrong?

I’m getting the same problem as Supramati, I’m kind of confused how to extract it, do I just extract everything into the project folder or do I have to make a plugin folder and put stuff in there?

I think I followed everything in the readme file correctly but when I try to use “CubiquityColoredCubes” or “CubiquityTerrain” it crashes on me.