"Cube" missing and Warning: Failed to load "..." Referenced by Cube

Hello,
I have once used the basic “Cube” to create assets and assigned of course other materials to it.

Now I get all the time at opening UE the warning, that the materials of the cube were missing, despite I’m in a completely different project.
Also the “Cube” is not available in the “Place Actors” menu. But I can find it in the library, a “Cube” and a “Cube1”

How to solve this?
Thanks

346889-cube.jpg

346888-cube1.jpg

You probably have deleted inbuilt engine content and saved over it. Never edit engine contents directly. Make copies of them first work with them.

Thanks for reply! But when I drag it directly from the “Place Actors” menu, then it seems not to be a copy.
So it means I can’t use that menu at all?

What sense does it make to have that panel, when it doesn’t create a copy.
So I have always to go into the directory and copy manually?

If I drag for example a spotlight from the light menu, it is an instance. This makes sense.

Not sure then! Try to find it in engine content!

This most likely happened when you were working on a project and accidently altered the texture on the default cube and saved it over the default EU texture.

You keep getting the warning as it keeps trying to pull a non-base-EU texture to the basic shape that comes with unreal, since the texture is most likely not part of the unreal default textures you will keep getting the warning.
You can check content viewer to see the path of the texture, but what you will want to do is replace the cube texture back to the default one.

Try opening a new project → drag a cube into the scene → select the cube and under details, under static mesh double click the cube, this should open an asset editor → under material slots, try the yellow arrow or manually set it to WorldGridMaterial → save and close the project, if it prompts you to save something over the cube mesh just accept → try opening unreal see if the warning keeps popping up

(if it is already set WorldGridMaterial try and save it over anyway)

Basically what you would be doing is just setting the default material of the basic mesh back to its default manually.

Other option is just to reinstall unreal, should fix that as well.

Hope it solves the issue, cheers!