CTF_UseComplexAsSimple Deactivates Physics


I want UE4 to use the complex Colissions in the meshes. But for some reason when setting it like this:

MyStaticMeshComponent->GetBodySetup()->CollisionTraceFlag = 

This deactivates the physics and nothing moves. The other tags of ECollisionTraceFlag work ok, but for some reason this one doesn’t and its super important when you want to have exact collisions.

Does anyone know if I’m doing something wrong or if there is another way?

Maybe set a mesh as custom collision as when we import fbx with custom collision meshes ( an undesired option because I cant set up each one of the meshes that I import with a custom collision mesh a part from its visual mesh, I want to use the visual mesh for the collisions also ).
A code example would be appreciated.