Download

CSV Data Table Import Error

I’ve searched for answers throughout the site, but thus far I’m stumped on this one. The code was built in VS2013 with DebugGame Editor, and I started the editor via Debug -> Start New Instance. A basic .csv file was created as a test case, but it simply refuses to import.

My data table is defined here:

3bc370f4b812b1a8923895bdbe68123bb58edf33.jpeg

My .csv export from Excel seems to be in order:

The standard error I see upon editor import:

Error.jpg

Any help would be appreciated. I’m sure I just missed something obvious.

~–RESOLVED–~

The import error seemed to be caused by the location of the .csv file:

C:\Game - Did not work.
C:…\Documents\Unreal Projects - Worked!

Lately I worked a lot with CSV, never had the problem. Can you try some different property types? I never used FText, only FString or FName. I am not sure if UDataTables can support every type.

My first test, with my actual game data, used FString and had the same import error. I’ll try it again just to be sure.

EDIT

Issue resolved. On a fluke, I thought I’d try to import from a different location:

C:\Game - Did not work.
C:…\Documents\Unreal Projects - Worked!

Now I can focus on importing the real information and parsing it. Thanks for the help!

This is a definition of one of my structs. Maybe add the constructor to it :smiley:

It turns out the issue was the location of the .csv file. Thanks for your help!

Nice you found your error :smiley:

A simple question my self…

Anyone found a solution for saving modifications to UDatatables on runtime?

I always change something in editor, then have to “Rightclick->Save” the file manually. Strg+S wont do the trick, and the Editor does not notice any changes automatically.
Anyone has a clue?

Guess it has to do with “SaveStructData()”, but it needs an Archiver and I dont know how to us it properly. Any advice?