Download

Crucial bug that needs to be fixed regarding marketplace

When attempting to add a product to the cart it says “you have 20 assets in your cart please complete the purchase first”, however, when clicking the cart icon, it says the cart is empty. I’ve filled out a marketplace form about this, however I’m post about it on the forums as well just in case.

The team is investigating this issue and may reach out for additional details on your ticket. We believe this issue may have been caused by the merger of the launcher and web browser carts, which had previously been separate.

Yes you are right about the merger, at least partially as it is half of the problem. Some feedback, basically when you guys had implemented a change to the cart months ago to limit it to only 20 items, I had nearly 200 items in there I believe(since I was using it as a wishlist) since that time after you changed the cart limit, I could not add or remove anything from the cart on the website, however I could still do so through the launcher, but recently you guys merged the website and launcher cart, so now I can no longer use the cart on the launcher either, I really hope if the bug isn’t fixed before next month that you’d give me access to this month’s free content at least.Thank you. In the ticket, they asked me to use chrome browser(which I’m not going to use.) If there’s another way I can provide feedback about the issue through another browser I’d be happy to do so.

I filled out another marketplace form with additional details.

Here are the two errors that occur on the website:

The following error is from BEFORE clicking on the cart icon, even though it wasn’t requested from before clicking it, it’s still relevant seeing as there is an error present:
“GET https://www.unrealengine.com/marketplace/api/shoppingCart 400”

The following error is from AFTER clicking the cart icon: "
“Failed to load resource: the server responded with a status of 400 ()”

I first posted about this in another topic back on 12-03-2018, 06:51 PM as seen here

I filled out two marketplace forms at the beginning of March. It is now Wednesday, April 3, 2019, and I still can’t add anything to the cart, nor was I given access to March’s free content, even though I explicitly asked for assistance because I’m not able to add it myself. So 5 months later and still no chance of using Epic’s services.

tried today, April 3rd 2019, added 5 items to cart when clicking on checkout, just spins forever. firefox latest version, no blockers.

So people are not only unable to access each month’s free content, but also now the spring sale. What are we supposed to do?