Critical Error on Host Server

So i changed the slate widget in my main menu for hosting a server from a specific widget that, when clicked, fired a delegate in another class to host a server (which worked perfectly) to a generic widget that has a FOnClicked slate argument that is assigned to a specific FOnClicked in the main menu class when the menu is built. this specific FOnClicked is bound to the exact same function that the the original widget FOnClicked, the only difference is that the generic widget instance’s generic FOnClicked is assigned to the FOnClicked that fires the delegate, rather than firing the delegate directly. can anyone see anything in this call stack that is obvious?

thank you:


Unknown exception - code 00000001 (first/second chance not available)


KERNELBASE + 37901 bytes
UE4Editor_Core + 2998748 bytes
UE4Editor_Core + 1620298 bytes
UE4Editor_CoreUObject + 332555 bytes
UE4Editor!CastChecked() + 174 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\coreuobject\public\templates\casts.h:30]
UE4Editor!IsServerDelegateForOSS() + 84 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launchengineloop.cpp:585]
UE4Editor!TBaseStaticDelegateInstance_RetVal_OneParam::Execute() + 13 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:812]
UE4Editor_Core + 1612257 bytes
UE4Editor_OnlineSubsystemNull + 136784 bytes
UE4Editor_OnlineSubsystemNull + 171875 bytes
UE4Editor_OnlineSubsystemNull + 103499 bytes
UE4Editor_MistOfTheDark!AMOTDGameSession::HostSession() + 685 bytes [c:\users\m\documents\unreal projects\mistofthenathan\source\mistofthedark\motdgamesession.cpp:329]
UE4Editor_MistOfTheDark!AMOTD_Menu::HostGame() + 351 bytes [c:\users\m\documents\unreal projects\mistofthenathan\source\mistofthedark\motd_menu.cpp:88]
UE4Editor_MistOfTheDark!AMOTDMenuHUD::HostGame() + 184 bytes [c:\users\m\documents\unreal projects\mistofthenathan\source\mistofthedark\motdmenuhud.cpp:229]
UE4Editor_MistOfTheDark!STestMenuWidget::HostClicked() + 405 bytes [c:\users\m\documents\unreal projects\mistofthenathan\source\mistofthedark\testmenuwidget.cpp:249]
UE4Editor_MistOfTheDark!TBaseRawMethodDelegateInstance_RetVal_NoParams::Execute() + 52 bytes [c:\program files\unreal engine\4.2\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:426]
UE4Editor_MistOfTheDark!TBaseDelegate_RetVal_NoParams::Execute() + 26 bytes [c:\program files\unreal engine\4.2\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:1058]
UE4Editor_MistOfTheDark!SGeneralMenuItem::WasClicked() + 92 bytes [c:\users\m\documents\unreal projects\mistofthenathan\source\mistofthedark\sgeneralmenuitem.cpp:62]
UE4Editor_MistOfTheDark!TBaseSPMethodDelegateInstance_RetVal_TwoParams::Execute() + 94 bytes [c:\program files\unreal engine\4.2\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:228]
UE4Editor_Slate + 1078122 bytes
UE4Editor_Slate + 2666975 bytes
UE4Editor_Slate + 633935 bytes
UE4Editor_Slate + 592823 bytes
UE4Editor_Core + 2624539 bytes
UE4Editor_Core + 2558849 bytes
UE4Editor_Core + 2629279 bytes
UE4Editor_Core + 2547554 bytes
user32 + 105425 bytes
user32 + 104666 bytes
UE4Editor_Core + 2630294 bytes
UE4Editor!FEngineLoop::Tick() + 3135 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launchengineloop.cpp:2073]
UE4Editor!GuardedMain() + 476 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launch.cpp:132]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:207]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]


Could you post your dxdiag, LOG, and DMP files? If you need to know where to find this info please take a look at the link below.

Thanks, TJ

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information.

Thanks, TJ

sorry, i was away for a few days. so i keep trying to add the dump, dxdiag and log files as attachments to this comment, but it says it can’t attach the files, because the extensions are invalid or unrecognized. i didn’t see in the link to the other post how that guy got them to you. soooo if you could dumb that part down for me a bit i’d appreciate it.

on another note, some potentially useful information, i ran a debug with native only on the dump file and found that it gave me the following information:


You can either zip them and that should allow you to post them here or you can put them up on Dropbox, Google Drive, etc. then post us a link.

okay, here are the files zippedlink text

I guess this is some sort of bug with PIE. I resolved this problem by selecting “Standalone game” mode under the Play options in the UE4 Editor. Also, this problem does not arise when the game is packaged.