Creation from a Selected Actor problem

The button marked with the yellow square is disabled here! What I did:

  1. Placed a box geometry into the scene after I create a new project.

Am I doing something wrong?

Hi pjrm1470,

Which version of the editor are you currently using? Also, could you post a screenshot showing exactly what you are seeing?

Unreal version 4.4.3
Here a print screen of it:

Okay, I see now. So BSP Geometry is different from Static Meshes. BSP are a quick way to block out your level and are made to be replace by (or converted to) a static mesh. Once you have a static mesh in your level, the ‘Create Blueprint’ button will be active.

To convert a BSP to a static mesh, look in the ‘Details’ panel > ‘Brush Settings’. You will need to click the down arrow to drop down the additional options. Choose ‘Create Static Mesh’.

You will see lightmap errors on the mesh, this is okay. Find the new static mesh in the ‘Content Browser’ and double-click to open it. Once opened, go to the ‘Details’ panel > ‘Static Mesh Settings’ and change the ‘Light Map Resolution’ to 32. Save the mesh.