Creating/finding steam session: does anyone know what I'm doing wrong?

My game (basically a new project) is unable to find a session and I have no idea what I am doing wrong.

I have a UE4.22.3 blueprints only project. I’m launching the game as standalone with the dedicated server box checked. I do get the steam overlay while playing, so it does partially work. I’ve tried setting the LAN property to true and false, same results.

I enabled the built-in steam plugin originally. I then disabled it and added the advanced sessions plugin and enabled it. I’ve switched back and forth and I have the same results either way. I get the steam overlay, but cannot find a session.

Attached are my related blueprints.

Game Engine.ini settings:





Does anyone know what I’m doing wrong? It’s likely something simple, but I’m new to UE and I’ve tried everything I could find aside from making a cpp project. Thanks in advance!

Your steamID to start with. I am pretty sure that is not the steamID of the game. Also, you do need a session search build from scratch (with UI) to even find one

Hey @Saltylele thanks for the reply! The steam ID I am using is the default dev steam ID (480) that is recommended in the documentation. Since this is a new project, I do not have an official Steam ID yet. Can you not create/search sessions w/480?

Can you please elaborate on what you mean by needing a session search build from scratch? I’m not sure I understand what you are referring to. For clarification, screenshot 2 is my session search. I didn’t include the UI stuff because it’s irrelevant to my issue. The blueprint code is being called, and it’s returning 0 sessions found every time. I am running it standalone with the “dedicated server” option ticked, which I believe should automatically create a session for me. Regardless, I have tried creating my own session too, then searching and I still get the same result (0 sessions found).

Thanks again for your time, I look forward to your reply!