Download

Creating a project with a Chinese name? Error!

Hi,

I am unable to create a new project with Chinese characters in the Unreal Engine.

I’ve been trying the same process with UE4 4.18 through 4.22 to find that I am unable to compile a C++ UE4 project in Visual Studio and I’m unsure why.

I receive the following error if I don’t change my class names from 立方迷城GameMode to TestGameMode:

/NewTest/???/Source/???/???GameMode.h(1): error : Missing UCLASS name

And I receive these errors after changing my class names:

1> [1/7] TestGameMode.gen.cpp 1>c1xx : fatal error C1083: Cannot open source file: ‘C:\Users\MY-PC\Documents\Unreal Projects\NewTest\绔嬫柟杩峰煄\Intermediate\Build\Win64\UE4Editor\Inc\绔嬫柟杩峰煄\TestGameMode.gen.cpp’: No such file or directory

1> [2/7] 绔嬫柟杩峰煄.cpp 1>c1xx : fatal error C1083: Cannot open source file: ‘C:\Users\MY-PC\Documents\Unreal Projects\NewTest\绔嬫柟杩峰煄\Source\绔嬫柟杩峰煄\绔嬫柟杩峰煄.cpp’: No such file or directory

1> [3/7] TestGameMode.cpp 1>c1xx : fatal error C1083: Cannot open source file: ‘C:\Users\MY-PC\Documents\Unreal Projects\NewTest\绔嬫柟杩峰煄\Source\绔嬫柟杩峰煄\TestGameMode.cpp’: No such file or directory

1> [4/7] 绔嬫柟杩峰煄.init.gen.cpp 1>c1xx : fatal error C1083: Cannot open source file: ‘C:\Users\MY-PC\Documents\Unreal Projects\NewTest\绔嬫柟杩峰煄\Intermediate\Build\Win64\UE4Editor\Inc\绔嬫柟杩峰煄\绔嬫柟杩峰煄.init.gen.cpp’: No such file or directory

I have changed my Windows 10 Region Locale to Chinese (Simplified, China), installed all Chinese language packs and fonts in Windows 10, and Chinese language packs in Visual Studio.

What am I doing wrong?

Someone on the AnswerHub has mentioned that we are only able to use alpha numeric for the project name here: Creating a project with a Chinese name? Error! - UE4 AnswerHub

If that is the case, how would I get the output .exe and the root content folder name and Windows to recognize the final product to appear as a Chinese name?

Thanks,
Jon

Hello,

Please look at this error message:

1> [2/7] 绔嬫柟杩峰煄.cpp 1>c1xx : fatal error C1083: Cannot open source file: ‘C:\Users\MY-PC\Documents\Unreal Projects\NewTest\绔嬫柟杩峰煄\Source\绔嬫柟杩峰煄\绔嬫柟杩峰煄.cpp’: No such file or directory

The c++ source file can’t named chinese name, at least i haven’t do it,(it need visual studio compiler support, i am not sure whether it is support),
It’s a good idea what use an english name for naming every source file in project, you can set a chinese name for Application through Unreal Engine Project Setting.

I think you can fixed this issue first.