Creating a file in a subfolder means #include file is incorrect

When using the editor command to add code to your project (via File>Add Code to Project), if the file is placed in a subdirectory of the source directory, the includes to the games main header is not correctly updated.

Specifically, it needs a ../ prepended. It currently reads:

#include "ProjectName.h"

but should read:

#include "../ProjectName.h"

for files that are nested within one folder (obviously needs more for deeper folders/include the root directory directly).

Pretty minor annoyance, but annoying none the less!

Which version?

It should detect whether the module header is Public or Private and include it appropriately (if it’s Private it will need the path, if it’s Public it shouldn’t since all Public folders are always on the include path).

Ah, I am a bit behind, version 4.2.1. It is just the game module, so there are no public/private folders. I suppose it defaults to private for game modules?

I think it’s 4.3+ which has the change I mentioned. I think that was also the version which changed the default to Public rather than Private… I’ll check to make sure.

EDIT: Yeah, just tried this with a test project and it worked correctly.