Download

Creating a custom character

Are there any good tutorials out there on creating a custom character or applying a new skin to the existing FPP and TPP skeletons?

I am very new to this and trying to create an enemy character to shoot at in the first person template. I’ve followed the offical “Third Person Blueprint” set of tutorials, but the thing is, I can’t figure out how to use my custom character mesh with the existing heroTPP skeleton and animations.

For a custom character you can nearly use every rigging/animating tutorial on youtube -> after that import the character + follow the 3rd person tutorial series. You could also export the blue character to your 3d program and there you could modify it :slight_smile:

Thanks, Fighter.

As a troubleshooting step, I actually tried exporting the blue character to fbx, then i opened it in 3d max. Without making a single change, I exported everything back out to FBX saving it as NCHeroTPP.fbx and tried to re-import into Unreal. I get an error message "Failed to import ‘…/…/…/…/…/…/3D/UnReal/TIGO/3d max models/NCHeroTPP.FBX’. Failed to create asset ‘/Game/Character/NCHeroTPP’

Then in the message log after the failed import, I get “error, could not import HeroTPP, duplicate bone name found (‘HeroTPP’). Each bone must have a unique name.” and a second error saying “Multiple Roots found”.

I thought it was maybe because I already had a HeroTPP skeleton mesh in the file, so I deleted it and tried to re-import but I get the same error messages.

For the root -> it means that in your object hierarchy there are multiple parent objects that everything else is linked to (multiple root bones). So you will have to remove one + probably this bone is also causing the 2nd problem

Ahh…yes. Ok, so when exporting HeroTPP.fbx from Unreal, for some reason, a dummy node called HeroTPP is also added to the bones system when you open it in 3D Max. If you delete that HeroTPP dummy helper, everything works like a charm! I’ve been fighting with this for four days now - so happy to have that sorted. Thanks for all of the help!
-Jesse