CreateProjectFiles ERROR:

Hi. I have now several days tried to install the “release” build of 4.10 downloaded zip version on my Win 8.1 and Win 7 computers with similar problem. I have VS2013 and VS2015 Community editions installed on both and both computers fail to generate project files. They are ither stuck when RunAsAdmin or give this error log.

It looks as VS is locking the files… What do I do about it?
I have tried uninstalling, reinstalling the VS 2013 and VS2015 but I stil get the same eror.
First time I run the .bat file it just freezes the second time without admin privs it gives the aforementioned errors

Hello lubtel,

A couple things to try. Could you move the engine’s files to a different location such as My Documents or something that is considered public? There could be permissions issues occurring inside the Program Files(x86) folder. If that doesn’t help, can you open your Task Manager to ensure that they are no processes running that could be attempting to access these files? That would include, but isn’t limited to, any UE4 or Visual Studio related processes.

On my Win7 computer…

I did move the files to My Documents folder. When I run(asAdmin) the GenerateProjectFiles.bat it is stuck with:
“Setting up Unreal Engine 4 project files…” message in the console… http://prntscr.com/93gqok

I just restarted before trying this and there should not be any processes interfering… :frowning:

Anything else I could try?

I’m not sure why it would, but can you check the processes tab of your Task Manager to see if UnrealBuildTool.exe is listed before launching GenerateProjectFiles.bat? If so, end the process. If not, launch GenerateProjectFiles.bat and see if it appears and if it is using any memory.

I did another restart, checked the taskbar. No build tool was running and started the GEnerateProjectFiles.bat
After that three instances of UnrealBuildTools are running in the backround.
http://prntscr.com/93hol4

while the console still shows the same message: “Setting up Unreal Engine 4 project files…”

Would you be able to have a look at it through Team Viewer?

ID:xxxxxxxxxxxx
passw:xxxxxxxxxxxx

cheers

That won’t be necessary, but I appreciate the cooperation. The problem is definitely surrounding the 3 instances of UBT as there should only be 1 and two running at once will cause conflicts. Can you try ending two of the processes while the .bat is running to see if anything happens? I’ll be looking into what could be causing this in the meantime as that is only a possible workaround and not a real fix for the problem.

It’s possible that it won’t work, that was only a possible work around. I’ll attempt to find the root cause and get back to you as soon as I can.

I try to kill the processes but so far without success. I use RMB>End Process. or RMB>End Process Tree.
But the processes are still there and there is no progress in the console…
http://prntscr.com/93i2uz

Is therre a better way to kill a process? Holding down a key or something?

cheers

Thank you very much. I have been struggling with this for three days now.

Uninstalling VS2015 helped with generation of the solution files. Now I will try and build with VS2013?.. At the same time trying to uninstall VS2015 on the Win8.1 computer see what happens there…

If you wish to use Visual Studio 2013 for building 4.10, you’ll need to use the -2013 launch parameter for the GenerateProjectFiles.bat to generate a project that is compatible with 2013. It defaults to 2015, in most cases.

Where would I provide that argument? Is description of this process described somewhere? Ideally if there is a downloadable .bat file somewhere on the net?

cheers

If you open the .bat file with notepad or any other text document editing software, you should see the following line:

call “%~dp0Engine\Build\BatchFiles\GenerateProjectFiles.bat” %*

Replace that with:

call “%~dp0Engine\Build\BatchFiles\GenerateProjectFiles.bat” -2013 %*

You can find more information about that at this forum post:

I have had too much to do at work, now getting back to this. It would be best to try and solve this with VS2015 no?
I have uniinstalled VS2013. I have downloaded the whole 13.7Gb UnrealEngine folder n-th time :slight_smile: I cannot generate the ProjectFiles without the VS2015. But when I install VS2015 the same thing happens again. There are three instances of UnrealBuildTool.exe running and I am unable to forceQuit these from Task manager.

Could it be an interferance from a prerequisite?

Will I miss out on something if I compile with 2013?

So strange because on the win 8.1 computer the UnrealBuildTool does not even show in the TaskManager when I start generateprojectFiles.bat. The console window shows the same"Setting up Unreal Engine 4 project files…"…

Could there be another Redistributable library or framework from microsoft conflicting with the build process?

I have ben struggling with this for over a week now.

You won’t lose anything other than compatibility with 2015 by compiling with 2013. When you go to generate the project files, are you still having the multiple instances of the UnrealBuildTool?

Edit: Ah I didn’t see that you said that it wasn’t even showing, that is definitely a problem too. Is the only on the 8.1 computer and not the 7 one?

Hi. I did reinstall VS2013.5 on Win8.1 and compiled with -2013 flag and it worked this time. But that is nt my main workstation. The main machine I use has Win 7 Ultimate. There I have done the same but I still get three instances of UnrealBuildTool.exe. :frowning:
What can cause this behaviour?
The VS2013 web installer crashed when started so I had to download the dvd version to be able to install. Could there be something in my system that is missing or should be uninstalled first?

I’m not quite sure yet what could be causing the multiple instances of UBT to appear but one thing that would be good to test is if your Visual Studio installation is working correctly. I would suggest making a simple code project outside of UE4, with basic .cpp and .h files in Visual Studio to see if it’ll compile on its own.