CreateExport: Failed to load Outer for resource

Hello all,

this is (almost certainly) a bug which I experienced working in a source controlled project together with a colleague. The attached file can be opened by my colleague, but I get those errors in the attached screenshot. He even sent me the file via e-mail but still no success. I already tried the suggestion from another post (deleting the Win64 folder from binaries and regenerated) …

To reproduce the bug:

  • Create new project
  • Copy the attached Tessa.uasset into it
  • Open the project in UE4
  • Right-click on the asset or try to open it, it should say “Failed to load assets”

If you have any ideas, let me know.

Hi MrBallantine,

The asset in question here automatically gives me errors, and more so than what you’re getting because it’s missing much more than you’re full project. I get ~700 errors. With that, the asset in question here isn’t going to be much help unfortunately.

Have you tried making sure that your colleague has checked in all files into source control and on your end try doing a full resync of the project. There could be changes with the asset in question that were not fully checked in causing the fail to load.

Without a set of repro steps to recreate from scratch I cannot verify if there is a potential bug here.

What I’ll need:

  • Set of Repro steps to reproduce this in a blank project from scratch
  • What source control software are you using? (Subversion, Perforce, etc.)
  • Are you using the Binary editor or Source Build from GitHub
  • Is your Build Blueprints or Code based?

Thank you!