Download

Create Widget cannot see some widgets on some Blueprints

Hi, I am very new to UE4 so I apologise if this is a dumb question.

I’m trying to make a simple menu system using Widget Blueprints. The menu currently has two levels which it switches between (‘Main Menu’ and ‘Career Mode’ - yes they are separate levels). I have created 4 Widget Blueprints to populate those levels with appropriate menus.

Twice now, however, after creating a new Widget Blueprint I have been unable to add it to the ‘Career Mode’ level where I want it to appear. When I add a ‘Create Widget’ node to the level blueprint it only gives me 2 widgets in the options dropdown (the oldest two) - the new widgets I have created do not appear as possible selections. Both times I found that I could add the new widget to the other level (‘Main Menu’).

The first time it happened I reorganised the flow so it was a submenu of the main menu instead, which was not ideal but did work. The second time I discovered that I could add the ‘create widget’ node in the main menu level blueprint (where I don’t want really want it), then cut + paste it into the Career Mode level blueprint (where I do want it), and once it is wired it up I can get the widget to appear on the right screen.

So, does anybody have any idea why some widgets would show up as options in ‘Create Widget’ on some Level Blueprints but not others? Other than different geometry (and menus, obviously) I am not aware of any difference between the two levels - though since one was derived from the simple starter level and the other was created from scratch (since duplicating the level seemed to be a 100% crash event) there might well be differences I am not aware of.

Are you working in one project or two different projects? Any way you can post some images of the issue?

Hi, thanks for replying.

Everything is in one project, but the levels and widgets were split across two subfolders (‘MainMenu’ and ‘CareerMode’)… the level in ‘MainMenu’ could see the widgets in the ‘CareerMode’ folder, whilst the level in the same folder as them could not, so I doubted that was an issue… however, I just tried moving everything into the MainMenu folder as a test, and now the CareerMode level can see all the widgets (it couldn’t when I first opened the level today, but after moving them it could).

I then tried moving the CareerMode level and its associated widgets back into the CareerMode folder… it can still see everything. i.e. everything is now working as I would expect it to. MainMenu can still see them all, too.

It wasn’t until I tried moving them and moving them back, though.

I had renamed the newly created widgets after creating them… might that have caused some confusion which a move-and-move-back could have resolved (cached names not updated somewhere on a rename, perhaps)?

I was going to post screenshots, but since it is now working it probably wouldn’t help?

OK, this started happening again, but I have figured out what the problem is… it’s all to do with the zoom level of the blueprint editor!

745f3f4e52ada1972d79ea4bbef89793bedf0035.jpeg Clipboard-zoom1to1.jpg

What made it extremely non-obvious is that the SEARCH BOX doesn’t even show the blueprint when zoomed out… it seems that the search only looks at blueprints that are visible in the drop down.

49cd806d16a72faf40fec7cd5d42aa5edbf79122.jpeg 1ef5e8c9dd292eabdfa2d9d73dfce9f29bfe691b.jpeg

There doesn’t seem to be any way to scroll the selection, either. Once I have more than 5 widgets I can see this becoming a rather serious problem!