Download

Crashing on play

Hi,

my unreal engine is crashing every time I press “play” on a level other than “FirstPersonExampleMap” (which works when I press play.) The textures also seem to be kind of broken every time I reload UE. I’ve tried making a blank level, and that also crashes on play. It’s a c++ project with blueprint code added on top, but I can’t imagine the c++ having anything to do with it since I only modified some of the properties of the FirstPersonCharacter in the c++, and that was a while back (and it still worked). Does anyone have a solution?

Thanks!

Hello, can you please share the logs? They should be located at `Documents/Unreal Projects/PROJECTNAME/Saved/Logs/PROJECTNAME.log

You only need to share the part where it crashes.

ok, I found the file once it crashed again (in documents, the unreal projects folder was empty, probably because I installed unreal engine on my D drive.) I clicked on the thing where it lead me to the crash directory. I THINK I found the log file you’re talking about, but it contains too many characters to be posted here. I’ll upload it to mediafire so you can download it, but if you don’t want to trust a random file on the internet I understand. Tell me if there’s a specific part you’re looking for:

Thank you!
PS. yes my project name is john_black. sorry.

Thanks for responding. Only about 20% of people actually follow up with the logs
That’s the right file, but it doesn’t include the crash. Here’s what you have to do:

  • Make the engine crash
  • Don’t relaunch the engine
  • Re-upload the same log file

I hope this works:

Ok, well this log looks like the other one (no crash). When you say it is crashing, do you see the Crash Reporter pop up, or does it just freeze?

From the logs, it just looks like it’s sucessfully loading and playing /Game/FirstPersonCPP./Maps/ia.ia

this is what happens when I press play on the ia map. Am I sending you the wrong log?

Thanks.

There’s nothing useful in the crash report because you don’t have the editor debug symbols.

Here’s how to get the debug symbols (beware, it’s a ~7GB download):
https://answers.unrealengine.com/questions/551532/how-to-debug-engine-code-get-symbols.html

The debug symbols will show exactly how it’s crashing.

ok, I did it. here’s the new log file:

OK. Let’s just give up on the log files. Can you send a new screenshot of the Crash Reporter? (Make sure to scale the window up so all text is visible)


sorry about the log files. Thanks for your patience.

Well, the crash is happening because SetHiddenInGame is being called on a USceneComponent at address nullptr. Perhaps you are calling it in one of your Actor’s BeginPlay functions?

ok, so… I got it working? I discovered something. Remember how I said it worked if I pressed play in firstpersonexamplemap, but not in any other level? I think I changed the specific actors variables at some time in the past. if I replace the one in firstpersonexamplemap with a default first person character, it crashes. I got the other levels working by copy pasting the one in firstpersonexamplemap, so now it works. I would like to find out what went wrong, because now I know there is a fundamental thing wrong with the blueprint, but if it works I guess I’m fine for now. thank you for your help and patience.

Could you try changing the DefaultPawn class to anything other than the FirstPersonCharacter, and see if that solves the crash? In the default shooter character’s BeginPlay function, SetHiddenInGame is called, which is probably causing the crash.

What blueprint? If this is a C++ project, then the FirstPersonCharacter is written in C++. Also, it’s really hard to crash the engine with Blueprints.

I tried removing sethiddeningame and it still crashed.

You’re right, it probably was something with the small amount of c++ I changed.

Sounds like it maybe something in your begin play function. Maybe paste in the code you updated in there. Could be a good spot to start.