Crashing in 4.4 launching from Visual Studio

I just updated to 4.4 today. (Downloaded from GitHub and compiled myself.)

When launching from Visual Studio with the project name as the debugging command argument, I assert out every time I open a map in F3D311Dynamic::RHI::CreateUniformBuffer() on line 207 because Inresources[I] is null.

If I launch without the command argument, and then pick the project, the map opens. If I launch by double clicking the uproject, the map opens. If I run the editor in Debug mode with or without the command line, the map opens.

Hi BrynBennett,

Could you provide some more information about how you are reproducing this issue? I created a new 4.4 project and tried to reproduce this several different ways and did not see the issue you described (I did get some error messages with some of the methods that I tried, but I was expecting those to appear).

  • Where are you setting your command argument and what is the exact argument you are using?
  • How are you launching the project using Visual Studio?

I’m just putting the uproject name in my command line. That’s the only argument I have. However, if I put -debug, I end up getting the same assert.

Additionally, if I do this from debug mode, the map also works fine.

Are you using the UnrealVS extension included with the Engine and that is where you are setting your command-line argument, or are you changing it in the properties for your project or the solution? Are you entering your exact project name, or do you use the macros available in Visual Studio?

When you launch the project, do you just press F5? What is your Solution Configuration set to?

Is this happening in a project that you upgraded from a previous version of the Engine? If so, are you able to reproduce it in a new project created in 4.4?

I’m setting it in the debug section of the properties for my game’s project in VS.

Yes, F5. The configuration is set to Development Editor. In Debug Editor, it doesn’t happen.

It is from a project that I upgraded from 4.1. I haven’t tried a new one from 4.4. I can give that a shot.

I created a project named “TestLaunch1” using version 4.1.0, then upgraded it through each Engine version until I got to 4.4.0. I then pulled up the project properties and went to the Debugging section and changed the Command Argument field to several variations of the project name.

These are the results that I saw when I pressed F5 (TestLaunch1 was set as the startup project in VS):

Using either TestLaunch1 or "TestLaunch1" in the Command Argument field:
“Failed to open descriptor file” error message.

Using -TestLaunch1, "-TestLaunch1", -debug or "-debug" in the Command Argument field:
The Project Browser opens instead of the TestLaunch1 project, opening the TestLaunch1 project stops Visual Studio debugging and opens a new instance of the Editor. I can open different .umap files without any problems.

Using the default value (seen in the image above):
The TestLaunch1 project opens in the Editor and VS remains in debug mode. I can open different .umap files without any problems.

Adding -debug or "-debug" after the default value:
The TestLaunch1 project opens in the Editor and VS remains in debug mode. I can open different .umap files without any problems.

Where do my steps differ from what you are doing?

Hi BrynBennett,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.