Download

Crashes when loading large models. (minecraft model imports from jmc2obj)

the problem too i think is that when this tool exports minecraft builds as a 3d file it uses every single block as a polygon which could really complicate things on bigger builds. I managed to get some stuff imported but on larger models it seems to crash the engine when trying to load.

not sure if it is doing so because of a memory limit? oddly i tried to import something i thought did not have as many “blocks” as my previous one which imported ok but still crashed :-p. using maya 2013 to export it to .fbx then import it into Unreal Engine 4… :-).

What is the polycount on the model? There used to be a limit back in udk, not sure if its still the case. I read somewhere around here that it was either lifted significantly, or removed. It used to be around 60 or 70k max per model if I’m not mistaken.

I don’t believe there is a limit anymore, for sh1ts and giggles in the Polycount Hangouts the other night, we imported an extremely high poly model (4-5 Million polys) from RealFLOW directly into Unreal Engine 4, it seemed to handle it pretty well and didn’t crash out. We were even able to apply vertex animated materials to the mesh and it worked.

That is good to know. Not sure what the issue could be then.