Crashes when editing Widget Blueprints

I am completely unable to edit any widget blueprints since this crash showed.

I’ve tried creating completely new projects, verified the install - but same problem exists.

I don’t know what else I can do (I don’t know which error log to post, I posted the one in the crash reporter).

error log on gist

Hello DevSaucy,

This is a known issue (UE-23217) that has been reported and sent to the developers for further consideration. I have provided a link to the original issue below. Please visit that thread for future updates. I have also provided the workaround available at the link provided.

Link to original issue: Assertion failed: IsValid() File:D:\BuildFarm - UI - Epic Developer Community Forums


Try using Window > Reset Layout


Make it a great day

Thanks, it worked! (I didn’t know what to search for when creating this issue)

Problem now happens on version 4.19.2. Same workaround works: reset layout. It seems to happen when you try to bind a function to a UI widget by selecting from a menu, but accidentally move the mouse cursor off of the menu while it is up.