Crashes, really often.

First of all, hi everyone! I’m new to this forum ^-^

Second… let me get straight to the point: I have problems with Unreal Engine.
I don’t know if this section is appropriate, if not I am really sorry but now is two weeks that I looked for a solution myself on forums, reddit, youtube or whatever site looked promising…

I had problems with DirectX (10 or 11 it doesn’t matter, both used to crash) but THAT was because of the GPU Drivers (AMD Radeon 5700). I have now switched to an RTX 2070S (and yes, before doing that I used DDU aka DisplayDriversUninstaller to get rid of graphic drivers and eventually audio drivers) and it was worth it, at least I thought.

GTA 5: Keeps crashing without giving errors, I don’t really know how to fix it since I tried lowering settings, resolution and switching to DirectX 10 but nothing worked, it crashes whenever he wants, during missions.

Rocket Leauge: Still no errors, crashed 2 times in a month but I don’t know how

Rogue Company: Fresh install, crashes after 2 games. Re-opening it brings me back to a crash after 1 game and an half (in the middle of the second game).

Tried to:

  • Lowering down settings
  • Lowering down resolution
  • Lowering down both
  • Playing in windowed fullscreen, windowed mode and full screen
  • Re-uninstall and install GPU drivers again
  • Update windows
  • Update graphic drivers
  • Downgrade graphic drivers
  • Installing UE4 APART consuming much more time than I should with a new game install

The thing is that Rogue Company actually gives me errors, different ones everytime but still it does, the last is:

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff


I noticed that with GTA removing the DirectX folder (C:\Program Files\Epic Games\GTAV\Redistributables\DirectX) and then verify game files to make it download the folder again works.

I also tried verifying game files of all the games.

Other things I did:

  • sfc /scannow
  • chkdsk
  • Memory Diagnostic

I WON’T Re-install windows, don’t ask me to do that.

Also, don’t try to say that I should try re-installing all my games at this point since IT’S USELESS!

Rogue Company was a fresh install, so was Rocket Leauge at the time of crashing.

I also tried disabling Windows Gaming mode and my power plan is to “Max Performance”.
Yes, I tried disabling Shader Cache too.

My setup:

AMD Ryzen 7 3700x
RTX 2070S
16GB RAM DDR4@3200mhz

My monitor is in 2k but as I said, I tried lower resolutions too .-.

Thank you for reading until the end, I really appreciate :smiley:

I’ll make more testing to be sure, using rogue company that is the most “crashy” game I have.

Apparently, this crash happens only if I use XMP up to 3200, if I turn it off and use my RAMs at 2133mhz it doesn’t seem to have problems. Should I change my Aorus b450 or my vengeance RAM? I would change both anyway, but I really want to know what you would do insthead

Try seting your RAM values to a safe setting. If you have 3200Mhz ram modules, set them manually to one lower like 3000Mhz and see if your system works more stable. Has helped me, when I bought new RAMs and suddenly the occasional crash started, when I had zero before forever. This fixed it again.

Thank you for the tip but… How should I exactly do this? I don’t know what to touch and how much should I actually touch so if you have any suggestions let me know please c-c

You can change this in your BIOS. Google the settings for your specific BIOS or download it’s documentation. It should be actually simple and safe to make this one small change.

GTA isn’t using Unreal Engine so if you’re having crashes in many games then it’s not a UE issue

1 Like

Turns out my freaking Extreme Memory Profile is configured in a messy way. I tried to change only my mhz to 3200 and my voltage to 1.35 manually without changing any other values and it looks like all works fine… I’m not 100% sure but I think this fixed.

If you want me to explain how to do exactly what I did to fix let me know! (Repeat, I AM NOT 100% SURE OF THE FIX AT THE MOMENT!)

Update: it didn’t keep… I still get crashes.
I already ordered a new moboa and new RAM to be safe but I will still try with 2133mhz just to let you know if this is the issue

After several days of testing, I can safely tell that my problem was the motherboard… Changed it together with my RAM.

TIP: don’t buy b450 boards, use an extra 30/50$ and buy at least a b550 to use 3200 DDR4 RAM, at least if you stay on Gigabyte.

​​​​​​If you can’t change motherboard like I did, I higly suggest you to don’t even try to go over 3000mhz (or near to them) on your RAM without expecting some BSOD or weird behaviour from your machine. It COULD be related to gigabyte only but I can’t test on every brand so… Don’t take me too seriously, I am not an engineer…

With that said, have a good time!