Crashed on project startup after renaming a blueprint

Ah well, i knew something will go wrong if I did that, but somehow I did this stupid move.

I wanted to rename a blueprint that is being used by another blueprint and after playing in editor to make sure it works, i restarted the editor.

Now it crashes everytime.

The blueprint is used as a ChildComponent by another blueprint and I guess it messed it up.

Note: I quickly found out that a redirector was still there with the old name. I deleted it and the engine stopped crashing on reload. Though my project has now a lot of broken references.


Hi ,

To ensure I understand correctly, you are no longer experiencing the crash, however you have broken references? Have you tried running “Fix Up Redirectors”? If this does not work you will have to manually replace the references, which should fix the broken reference errors.

Hey ,

Thanks for your attention. There is a confusion it seems. The project wouldn’t start at all. It would crash on startup, preventing any fixup redirection process. I had to manually go in the folder and delete them to fix the problem.

Although it broke many references to that actor.

What I mean is, now that you are able to open the project, are you able to fix up redirectors to address the broken references or did manually replacing the references work?

I had to manually fix the references, and now it works again yes.

I am happy to hear there is no longer any crash and that you are able to continue on with your project. When did the crash first start occurring? Do you have any steps I can take to reproduce the error on my end?

  1. Create a Blueprint (A)
  2. Create a second Blueprint (B)
  3. In blueprint A, add B as a child component
  4. in the blueprint A, create some script referencing the child component
  5. save and restart
  6. rename B
  7. save and restart

This is where I crashed

Hi ,

Unfortunately I was unable to reproduce this crash using the steps provided. For now, I am going to mark this as answered for tracking purposes as you are no longer experiencing this crash. If this occurs again, please comment with updated information and I’ll be happy to take another look.