Crash when undoing `Collapse nodes`

If I try to select Collapse nodes on my iMac and then undo with cmd+z editor crashes every time.
Also, you can’t undo Expand node.

Hi ,

I haven’t had an issue when using Collapse Nodes or Expand Node and undoing on Mac. Can you give us information in Crash Reporter window when this crash occurs, and /attach log from project? You can find log in project’s Saved\Logs folder. Thanks!

Hi ,

We haven’t heard back from you in a while, so I’m resolving this post for tracking purposes. Please let us know if this is still an issue for you, and if so please provide information requested above. Thanks!

Hi , I’m having same issue on Windows 7, so I don’t think is SO related.
A few times editor has crashed on me when using “Collapse Nodes” then intermediately pressing Ctrl+Z.
It not always occur, I can’t find all exact conditions to reproduce bug, if I found them I’ll back with updates.
My logs text

Thanks for log, piXelicidio. This looks similar to other crashes we’ve had as a result of Undo, though it’s different enough that I’ve emailed developers about it to see what they think. I’ll let you know what I find out. Thanks!

Okay, this appears to be a separate bug with same generic callstack, so we’ll need to find a way to reproduce it. How frequently does this occur? Does it only happen in one project, or in any project?

Next time this happens, please copy information in Crash Reporter window, including MachineID, and paste it in a reply. I’d like to see if we can get a feel for how many people are running into same crash. Thanks!

Hi ,

I get exact same issue as well. Here is a crash log of problem.

To reproduce:

  • Right clicked → uncollapse node
  • Cntrl + z
  • Should crash

Hi Kanibel,

Was this with 4.8.3, or with 4.9 Preview? Can you attempt same thing in 4.9 Preview if you haven’t already?

What you zipped up doesn’t actually contain file i need: we’re looking for .log file from project’s \Saved\Logs folder. See if you can reproduce crash, then copy information in Crash Reporter window, including Machine ID, and paste that here (make sure you hit Send). Then grab most recent .log files from that folder and attach them. Thanks!

Was with 4.8.3

Crash Reporter Window Info:


No minidump found for this crash.

log file is here

Let me know if you need anything else!

Hm, it didn’t get submitted. Did you hit Send?

Does this happen 100% of time with same repro steps? Can you reproduce it in a new project, or does it only occur in your current project? Are you able to reproduce it in 4.9 Preview?

Yep certainly did!

Happens 100% of time in my current project (which is using 4.8.3)
I’m on Windows 10 and have successfully reproduced it on two other PC’s, one is on Windows 10 other is Windows 8.

However it doesn’t appear to happen in a new project created in 4.8.3.

Haven’t tried 4.9 Preview yet, were you still interested in getting me to reproduce it?

Yes, please try same in 4.9 and let us know. 4.9.0 was released this morning, so I’d like you to test in there if possible.

If it doesn’t happen in a new project, we may not be able to reproduce issue here. If you’d like, you can upload your project somewhere and send me a download link. You can do so privately via forums if you’d prefer:

UE 4.9 Seems to have fixed it :smiley: Thanks for that!

Not trying to brown nose but seriously loving support Epic gives community and size and quality of updates!