Crash when typing [ on Mac

Hello,

I was using Unreal Engine 4.7.6 on my MacBook Pro 15" (late 2013) with Yosemite 10.10.3 installed. I was in an Actor Blueprint, typing a String in a PrintString function, when I tried to insert a [ character. This caused Unreal to crash. I started it again, tried to make it happen again, and it crashed again. I started filling in a bug report in the Crash Report, but typing [ made crash the Bug Report…

I think the key information is that I’m using a ES-ISO QWERTY Apple integrated keyboard. It’s ALT+(the key right to the P) on this layout to make the [ character. I think this could be bind to some other feature in Unreal that make it crash.

You can see here the layout of the keyboard: http://i.imgur.com/3Vsc45A.gif

Hello ZetaKebab,

I tried to reproduce the crash you are experiencing on my end but was unsuccessful. I took a look at the keyboard shortcuts within the Editor Preferences menu and found that the ‘[’ key is bound to increase the grid size. I attempted to enter this key within a print string and did not experience any type of crash. I also took a look at the other symbols on the same key and the ’ key opens the console command window. This could be what is causing the issue but I cannot be certain.

Try going into your Editor Preferences and within the ‘Keyboard Shortcuts’ section, remove the bindings for this key and see if you are getting the same crash. If you do get the crash to occur again, please respond to this post with your callstack, crash logs, and dmp files generated from the crash zipped into a folder and attached to your reply. Also, what actor blueprint were you attempting to edit when you got the crash? Would you be able to reproduce this issue in a new blank project?

Thank you,

Andrew Hurley

Hello,

Note that the key of [ is not the same key as ', it is the same as ` and ^.
I deactivated the binding of the key for the grid size, but the bug appeared whatever I did, anywhere in the interface. I tried with a blank project, and I also crashes. As an additional info, it also doesn’t work with the 4.6.1 version.

Please find the crash logs and dump files attached!

Hey ZetaKebab,

Thank you for the crashlogs as well as the extra information. Once I have run a few more tests and verified this as a bug I will return here with more information. We appreciate your patience while we work to get this issue fixed.

Cheers,

Andrew Hurley