Crash when trying to load level trough UMG

I am trying to make a menu trough UMG and I use the open level blueprint node and I crash isntantly, and this is the error I get: MachineId:2745F229497CB83F4E9976A63FB29480EpicAccountId:ba277ee2fccc475dbfb07a - Pastebin.com

I am using 4.5.1

In 4.5.1, is it already fixed that you have to remove the Widget before using “Open Level” to prevent the crash? If not, would you mind trying to remove the widget when opening the new level?

Hello fanzypantz,

I would like to ask you a few quick questions to try and narrow down the issue that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If you reproduce this, can you provide accurate steps to reproduce it?
  3. Can you provide a screen shot of the blueprints you were using during/ just before the crash occurred?
  4. Could you please provide a dxdiag?
  5. Just to cover our bases, can you make sure that you are using the correct name for the level?

These questions should help us figure out where we should start digging.

the thing is, that in another level I have a HUD widget displayed at all times, and I only adjust the opacity when respawning and opening the level by pressing R(platformer game) so on the level you have the hud actually active, but just opacity of 0 on all elements. I can spam open level on that map, but the Main menu map is a clean map without anything, and the only difference really is that I am opening the map trough the UMG blueprint, that might be the issue tho.

Another thing I noticed, if the UMG HUD was loaded and I just instantly opened another level, the UMG from the last level would still overlay with the timer still going and everything. As if the UMG is constant trough all levels if you load it. I can see why that would be useful, but I’d first imagine that as well would reload when a clean load of a level happened.

I’ll come back with some more images and the stuff you wanted.

http://puu.sh/cYpUp/f03e7cce73.png
http://puu.sh/cYpXe/94dae204cf.png - current level has been the same for a while, the naming is correct.
http://puu.sh/cYq2Y/cdf18a385f.png tried to call the command trough gamestate http://puu.sh/cYq7n/cc7fb9227e.png

Then I tried this: http://puu.sh/cYqou/d0ca59db3a.png - http://puu.sh/cYqqn/d0a0291e29.png - http://puu.sh/cYqrs/e1abd1939a.png

And it worked. So basically you can not open levels directly from UMG or the issue was with that UMG blueprint in itself, so when it was removed from viewport it was fine. But I can load another level with my other UMG blueprint loaded. The one difference between the two UMG blueprints was the buttons. My other one only have text blocks and images.

Should UMG be constant trough all levels when the game is loaded? or should they “turn off” when you load another level? Because now it seems like they don’t get unloaded. Which is fine, it can be done manually ofc.