Crash when opening Blueprint for UI

When I try to open a Blueprint for the Main Menu that I was working on, my Unreal Engine crashes with the error of:

[2015.11.15-01.55.03:646][914]LogWindows:Error: Windows GetLastError: The operation completed successfully. (0)
[2015.11.15-01.55.03:779][914]LogWindows:Error: === Critical error: ===
Assertion failed: IsValid() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Public\Templates\SharedPointer.h] [Line: 739] 

All I did was try to copy and paste some elements in the Designer. Here is the broken file

EDIT: I just tried the backup files stored in Saved/Backup/ and it still crashes even with those files replacing the one I thought was broken. The file also causes a crash in another project.

Hi there,

Can you open the widget editor at all? Create blank project → create a widget and open it?

I can’t open any widgets now, and I just reinstalled Unreal Engine 4.10 and it still occurs.

So…, you’re having this:

and this:

Same here.

I thought it was something I did :smiley:

I put my project under source control, assigned a task, made the change and submitted it to the repo and was happy because it worked. Went back to repeat the process but discovered none of BP widgets opens. The UE4.10 Editor crashes every time I try to open a widget.

I can play levels, view models, and view BP GameInstance, BP GameMode, but I have not tried loading a main level and modifying it in the Editor though.

What are the chances of this getting fixed today?

Well that’s a bummer.

I was able to load and modify a level in the Editor, save it, push to the repo, and that worked. Then I decided to build the game and give the build version a run through. Unfortunately the runtime version of our game crashed.

I was looking around and I found this: Assertion failed: IsValid() File:D:\BuildFarm - UI - Unreal Engine Forums

Basically, go to Window → Reset layout.

Right. This works. Thank you.

Yeah I have this issue now as well. Caused when I accidentally corrupted a widget doing things I shouldn’t. tried many things to fix but was unable thus far

Yes, thank you :slight_smile: