Crash when loading project - access violation (code c0000005)

I’m getting a crash when I try to load my project in the latest version of Unreal. The project loads up to 93% and then crashes. This seems to have been triggered by recent changes, and possibly Perforce problems.

The crash has been unreliable in strange ways. It was working fine, then I made a small change which broke it. Upon reverting that file, the crash is still present! Perhaps the blueprints need to be recompiled, since the old version does not work? Is there a directory I can delete that contains the intermediate blueprint compilation?

The actual error is “Access violation - code c0000005 (first/second chance not available)”. The full callstack can be found here: http://pastebin.com/MTRE5Hip

Any ideas?

Hi bvisness,

You can try deleting the Intermediate and Saved folders from your Project folder and/or the DerivedDataCache folder from the install directory.

In order for us to address the bug, could you please provide in detail what changes you made to what Blueprint before the engine started to crash?

-.

It appears that we’re having this issue crashing at 93% based on editing a pawn. We can revert it to a stage when we can load it, but then as soon as we modify it (add any node) it crashes the launcher.

Tried zipping and putting it in a new folder, tried deleting intermediate / saved / derived data cash.

We’ve isolated a pawn. When you modify it in any way and save, the project no longer loads. Even if you delete intermediate or zip / deploy in another folder. We’re having the same problem across all machines.

If you migrate the pawn and associated files to a blank project, does the crash still occur? If so, can you provide the blank project to us so we can examine the cause of the crash? If you’d be willing to help, please send a link to the zipped file on Dropbox, (Google Drive, etc) to me on our . -Thanks!

I just built the master branch (4.15) and it’s resolved all of our difficulties. Thanks for your quick response, you can mark this closed.

Thanks for letting us know the issue has been resolved in the master branch.