Crash when importing tiled maps from WM "The asset failed to save"

When I import a tiled landscape from WM to Unreal with only the height heightmaps it works, I have the full 16,144x16,144m to walk on with PIE, but if I import the same map with a material attached with r16 heightmaps corresponding to different colors (exactly the same setup as the Unreal tutorial for tiled maps in the wiki) it crashes after running the “The asset cannot be saved” error once for each different heightmap.

I even tried loading only one of the heightmaps to try and understand if it was any of them and it crashes any way.

I tried now with r16 heightmap for height, and .raw heightmaps and it seems to be working although it did appear the same error but then the program proceeded to render the heightmap, and it colored the map, although the colors weren’t placed as they should, with several being off position.

PS: I’m using UE 4.14.3 with Windows 10

Hey dpmn,

Similar to your other post, I am going to need more information in order to effectively assist you with this issue.

Firstly, when it comes to crashes we will always ask for repro steps in a new blank project, the crash logs, and your dxdiag.

Secondly, if there are visual issues or discrepancies, it can be far easier to take a comprehensive screenshot so we can better understand what you are experiencing and reporting.

Please provide as much information as possible in your initial post, so the troubleshooting/bug reporting process is more efficient. This will also help us resolve the issue quicker, and possibly provide you with a workaround.

Thank you,

Hi again!
I think the problem with the texture placement might be related to differences in the height measurement of WM and Unreal? As I defined the outputs on WM based on height intervals it seems that my “water” output was placed way above what was meant to.

My main concern is that I’m not able to import .r16 heightmaps to define color areas in the map. The .raw makes paints approximatelly 1 meter wide pixels in a 16km-sided square which makes everything look bad.

I would send you the outputs but it’s 3,5GB!

I’m attaching my world parameters from WM maybe that can be of use.
After that I create a new level in Unreal, save with World Composition enabled, I import tiled landscape from levels menu, choose my height files, choose my material that’s ready to receive the heightmaps (which worked with the .raw files albeit with wrong height), and when I try to import the map it crashes.



Are you making sure the overall resolution of your landscape is within the guidelines of the Landscape Technical Guide?

Set the overall resolution of your world machine and then select the +1 option when exporting. This is done because connected components share a row of vertices, and there will always be one more row of verts than there are quads. The number of quads is what is going to define you resolution on a per component basis.

I don’t have a .r16 file to test in order to get it to crash, so I would need a way to reproduce this in a new blank project in order to report this bug.

Let me know if you have additional questions.

Thank you,