Download

Crash when clicking on Foliage

Hello,

I had this issue a few days ago with the Foliage Feature. I planted and draw some Foliage on my Terrain and had the idea to save the settings as “InstancedFoliageSettings object” and later on I closed my Project. Then again when I tried to start the Project again I either seem to have forgotten about to save the Settings File, or it didn’t sdave at all (I’m not sure about that), but I wasn’t there anymore and I recieved an error. Now everytime when I wanted to click on Foliage to maybe delete the settings file or so It would automaticly crahs when I click on Foliage and there seemd to be now way to get out of this situation and Foliage was unusable for me.
Lucky I found out when clicking on the Error Message I was able to select the Foliage and delete it.
So it was kinda fixable but the outcome was that every Foliage I placed was now gone (which isn’t a big deal since I hadn’t build anything big with it yet) but still that seems to be a small issue which should be addressed. Rather than crashing it should give you an error and set it back to default values or something.

Greetings

I’m seeing this bug as well & I believe it was also triggered by the act of saving the foliage settings for individual meshes. Now I get a crash each time I attempt to paint foliage.

Have you added a wind effect or any other stuff that has to do with the world position offset into your material? When yes, then delete it and try if you are now able to paint with the foliage tool. Because I had this problem in the beta and there my wind effect was the problem :slight_smile:

I was able to replicate the crash experienced by “Nobody”. It seems that when you save the Foliage settings, it actually doesn’t create the necessary uasset. This can be proven by locating the Foliage setting in the content browser and right clicking and clicking “Show in explorer” (It won’t show it). But if you double click it, modify it then save it, then save your map, the uasset will be created. This is a workaround to prevent it crashing and allowing you to use the foliage tool again.

Hello everyone,

Has anyone posted this crash to the AnswerHub Bug Reports section yet? (I have not found it in a search)

We would appreciate if you could make an AnswerHub report for this issue, including exact repro steps for getting it to occur. The AnswerHub allows us to track and assign out bugs better than we can manage on the forums, so we request that all bugs be reported there. Please see the link in my signature on the ideal format for reporting bugs.

Thanks!

Thanks Fighter,

I was bummed out for a few days cause I didn’t know how to get the foliage tool working again. After reading your comment I decided to try to see if what you mentioned was the cause. It turns out it’s something else and I’m not quite sure yet what it is. What I did discover was that it had something to do with that specific level. First I tried to use the foliage tool on another level; it worked. Next, I took the landscape object from the crashing level and moved into into a new level. I used the foliage tool there and it worked. When I get the chance I’m gonna test out to see if it has anything to do with Level Streaming Volume that’s tied to the level that crashes. The good news is I can continue to develop that landscape again. Thanks.

I’ll try to remember to add the results of my test here later.

Report Filed

Thanks this is useful

Thanks, this is useful.

I’ve updated my running project from 4.24 to 4.25. in 4.24 everything was great, no errors. but in 4.25 just couldn’t change or erase any foliage. If I try to use erase brush or select individual foliage and press delete. Bamm Engine crushed.