Crash using any blendspace in a packaged test

I’ve tried several options, but whenever a blendspace is in an animation path and you try to run packaged build it crashes with

[2021.09.02-17.14.41:556][209]LogThreadingWindows: Error: Runnable thread Foreground Worker #1 crashed.
[2021.09.02-17.14.41:556][209]LogWindows: Error: === Critical error: ===
[2021.09.02-17.14.41:556][209]LogWindows: Error:
[2021.09.02-17.14.41:556][209]LogWindows: Error: Assertion failed: BlendSpace != nullptr [File:D:/build/++UE5/Sync/Engine/Source/Runtime/AnimGraphRuntime/Private/AnimNodes/AnimNode_BlendSpaceGraphBase.cpp] [Line: 13]

This is just a test project with only 1 moving actor


I’m having the same issue. It builds fine and I can start the build. But as soon as my character spawns it crashes with said error.

For me it was because it had a 1d blendspace, when I changed it to a 2d blendspace it worked fine

I’m using 1D, but changing to 2D didn’t help for me :frowning:
Update: It might have helped on 2 of them, the third one is still causing issues. Just having it in the graph makes it not work… Still looking into it.

“Solved” mine for now: I had three 1D blendspaces. Now two of them are 2D blendspace and the third I substituted with a Blend Multi node and I can run it. (Works well enough for me right now, but it seems broken in multiple ways.)

Getting this exact same error as well, UE5-EA2. Works fine in preview, works in editor play, but crashes packaged projects. Simply removing blendspace nodes is the only “fix” I’ve found.

Its the same with me, having a blendspace in general, 1D or 2D makes my packaged game crash. However completely removing it, makes the game run fine. Also using UE5-EA2

Same. After packaging, throws out the error: Blend Space! = nullptr. And the project does not start.

Update: This problem is not observed in version 5.1 (current ue5-mine)