Download

[crash (UE5)] UE5 editor crash after start linux

after the short war ( the 6 day battle to get UE5 to compile an run ) the editor now starts
progress , much ground has been won , many hours of build time , driver changes and sifting though crash dumps and logs later

now the editor launches ok , the menus all work (after finding out how to get the font sizes to a scale i could read , ie bigger than 4 pixles high on a 64" 4k tv) )

but alas seems the battle is not over , the menus seem fine , i can move around and explore the default project fine , as soon as i try to select an object , the dreaded crash window returns , its not dead yet ,
LogCore: === Critical error: ===
Unhandled Exception: SIGFPE: floating-point exception

as far as i can tell this is down to yet another unresolved driver or module rather than an engine/editor bug , so no real point placing a bug report over it

but where , so my question is , is there a list of o/s driver/module dependencies needed in order to run on linux ? ,
this would greatly remove the need for devs to answer (noob) questions that are the result of missing drivers/libs or other system dependencies needed ,

at the moment it seems to just plough along regardless until a missing function is called then it just all falls over and fails , leaving us at a loss to know what function , lib , module or driver it was looking for , let alone what version of that, that it tripped over this time

leaving us looking like a cat , chaseing its mouse , skidding across a smooth floor , clawing frantically , trying to come to a stop , before it ends up , embedded in the wall

It is a shame you had such a difficult time getting UE5 to run.
I have not had the same issues that you are mentioning here.
The instructions in ‘Engine/Build/BatchFiles/Linux/README.md’ have been very consistent on my fedora distros for getting UE5 and UE4 to compile. I started to follow the path from Setup.sh to the other scripts and look for the list of dependencies it will attempt to perform an install of for you (on ubuntu that I know of), but realized this was not the answer to your question.

As far as ‘Noob’ questions, I’m not sure that is the correct term. I guess there needs to be a bit of understanding with regards to the status of “early access”. The UE team seems to still be filling out their wiki with information and the UE5 build instructions are not there yet like the ones for UE4 @ Linux Quick Start | Unreal Engine Documentation where it does offer reference to a mixture of OS and hardware requirements. The repo README.md seems to be the next best thing. Using “noob” questions just seems derogatory and there is no reason to put yourself down like that. It is just really a matter of proper documentation, which for now seems lacking, and for someone who is new to the community, where to look for it.

I am interested in the manual things you had to install and steps performed for your linux setup. Could you provide any insight into your distro, driver install, and hardware? I am trying to create a build farm for multiple distros that would deploy a fresh distro install, install video card drivers, then perform a pull from the latest stable release of UE5 and UE4 to help test out the build process. And maybe answer some of these questions.

i used the term (noob) as someone new to the program , and not skill based , ie needing to know the “quirks” this app requires to run , over actualy finding bugs that need fixing , from doing linux dev work the trem was often used in that context , because devs can tend to get bogged down answering such questions , that in turn slows down the time they can spend doing the real work , coding and bug fixes

anyway , issues , the most supprising issue is the dependncies , or lack of testing for them by the build system
make for example does not check to see if one of the libs its calling is actual installed (by rights it should fail saying missing ) , but i can also see that in a cross platform build like this the lib it self may not be on the build system and its assumed its on the target , even if the build and target systems are the same ,
this in itself seems to be the issue leaving us looking for a lib/module etc with no clue as to what it is or what provides it

ie finding i needed to add vulkan drivers (the nouveau ones )
at this point the build started to run and get to the create project menu , but failed on opening new project , even though the console messages were showing a group of red crash messages druing startup
i finding i needed to use the nvida drivers rather than the nouveau drivers fixed this , allong with a git commit done for a bug at the same time

anyway now i have it running as far as opening the new project , and a nice editor window , with the default scene , most of the menus seem to work (although not checked everything yet) but as soon as i select one of the scene items it crashes
to solve this so far spent hours of searching trying to find a list of libs/modules needed (failed) , in a last ditch attempt i started my package manager , and installed any relivant 3d lib or lib extentions i could find , arround 300 individual packages , but still te same issue (although in the long run if there needed it may solve further issues)

so currently it starts , i have one error (LogAutomationTest: Error: Locale is “en_GB.UTF-8” but should be “C”. Did something call setlocale()? )
hmm not looked into that yet
and not a marked (red line console error) but a message about openXR

LogHMD: Failed to enumerate extensions. Please check that you have a valid OpenXR runtime installed.

so although i dont have any VR on this setup it does seem fair that i need the drivers if only for the sake it checks to see for itself
and as its not in the package repo i did find it a soucre repo for it on git , my next task will be to build and install it
although it remains to be seen if this is the issue
i have flu atm so not got much further as yet

its also fair to say , most of the UE4 issues and notes are somewhat true to UE5 builds , given that UE5 has slightly differing requirements

as to system and o/s
im using opensuse tumbleweed (build rolling current updated daly/weekly to current latest )
so its fair to assume the installed from repo drivers/libs/modules and apps are current to that (too many to list here)

system is a dell t7600 , twin cpu xeon e5-2680 (gives 32 cores with ht @2.7ghz)
64gb ram
nvidia GeForce GTX 1080ti

and building using the UE5 5.0 git repo

kool but other than the tec issues of doing it the way you are on about , there are other issues that of licencing especialy with drivers like the nvidia drivers , that are not opensource , so you cant just package them with your build , infact its why you dont get them by default with distros and have to manualy get and install them from nvidia

what you have to do is test for them , and exit requesting that the user install them (exit with a list of all of the missing ones if possible), especialy for those that are not in the package repos, ie build from git packages or poprietary drivers , i have seen other packages that employ this method , but for the life of me i cant name them , or pinpoint any opensource ones that you may peek at the code to find out how to do this , but its worth a look
and better alternative to possible legal action ,

also have to add , at this point i also have a short list of other apps that i need to sort out once i have the main UE5 build working , as seems there not a requirement but are important to workflow
Epic-Asset-Manager(GitHub - AchetaGames/Epic-Asset-Manager: A frontend to Assets purchased on Epic Games Store)
and the blender plugins( Home | Blender Tools Documentation )

bit further …
just built and compiled OpenXR
there is an isue with building it on tumbleweed and a few other distros , that is probalbay best described here
https://vulkan.lunarg.com/issue/home?limit=10;q=;mine=false;org=false;khronos=false;lunarg=false;indie=false;status=new,open
knowing this theres a easy quick fix way to cope with this ,
just link* all the files in usr/incude/wayland to the ~/OpenXR-SDK-Source/src/common/ directory and run :-
make
su
make install

, all done make install needs to be run as root , and needs to be done to install the lib on the system , they fail to tell you in ther docs

(link not copy so if updated later , it updates both and its not a biggy issue)

but still crashes as soon as i try to select an object in the editor
this is on the default blank project
it exits without a crash report for some reason making it hard as a trace log would help here

so list of errors only from the startup console anyone know if any of these errors may be the issue ?

Failed to initialize subsystem dependency (WorldPartitionSubsystem)

FVulkanPipelineStateCacheManager: Binary pipeline cache ‘…/…/…/…/…/Documents/Unreal Projects/blankproj/Saved/VulkanPSO.cache.10de.1b06’ not found.

Unable to read VR Path Registry from /home/david/.config/openvr/openvrpaths.vrpath
[2022.01.10-15.19.41:779][ 0]LogHMD: Failed to initialize OpenVR with code 110

and the ojects in the inital sceine all are giving the following when loading
s
[2022.01.10-15.23.46:918][ 0]LogStaticMesh: StaticMesh /Engine/EngineSky/SM_SkySphere.SM_SkySphere should be resaved to improve async compilation performance.
[2022.01.10-15.23.47:253][ 0]LogStaticMesh: StaticMesh /Game/StarterContent/Architecture/Floor_400x400.Floor_400x400 should be resaved to improve async compilation performance.
[2022.01.10-15.23.47:268][ 0]LogStaticMesh: StaticMesh /Game/StarterContent/Props/SM_Chair.SM_Chair should be resaved to improve async compilation performance.
[2022.01.10-15.23.47:281][ 0]LogStaticMesh: StaticMesh /Game/StarterContent/Props/SM_Statue.SM_Statue should be resaved to improve async compilation performance.
[2022.01.10-15.23.47:292][ 0]LogStaticMesh: StaticMesh /Game/StarterContent/Props/SM_TableRound.SM_TableRound should be resaved to improve async compilation performance.

wonder if the fact they need to be resaved is causing the issue ?

at a loss here now , running out of things to check


success at last

found another d3d driver i had missed installing when i did my first driver hunt , installed that , git pull , etc , to build , ran this time i created another new blank project , with quality to (scailable ) so i can resize the windows and fonts so i can read them on this 4k 64" monitor without a magnifying glass , spotted a little red message this time that i could read top left side of the main editor window
saying lighting needs to be rebuilt , did this and wooo can now select objects without it crashing ,
so still not sure if its the first step or the last step that fixed it ,
ho and i broke the openxr build in the process by linking the usr/incude/wayland files to usr/include , this may have inadvertantly fixed vulcan ,as it also depends on it but did not complain about it
so it also seems to appear openxr is not needed unless you have vr hardware

update , well the good news is (if you can call it good ) the above was not the reason for the crash , and the cause turns out to be the result of something compleatly different ,
see post Fix the Linux UI, Context Menu, High DPI Sizing, Resizing - #5 by achiestdragon

Glad to hear you figured it out.

Given all the work you put into figuring out how to get the build and runtime dependencies satisfied are you planning on doing a write-up of some kind for opensuse tumbleweed?

dont know if i have the time to do a full writeup , but the error this thread relates to , and the steps i took , many of them turned out not to be the cause , and probablay are unnessacery , so a quick summary …

the descovery that the crash issue itself is related to the font dpi monitor settings , with the nvidia drivers , a strange one at that , and yes i can confirm it as it depends on the monitor i have set to primary ,

with the dell p2815q monitor primary , not only does the system start to correctly honor high dpi fonts but UE5 engine works ok

but with the sony tv as primary , the system fails to honor the high dpi fonts , (super tiny fonts every where , more noticable on gtk apps that fail to honor the kde system overides , UE5 editor starts , but crashes once you select an object

this appears to be down to the fact that the sony tv does not have a device profile within the drivers , so the error may affect other monitors that also dont

all i can add here is i suspect those with a high dpi font issue in opensuse tumblweed (maybe other distros also) with not just UE5 but other GTK apps like google chrome
on switching to the nvidia drivers rather than the nouveav drivers when this problem seems to appear

saying that in my case , just setting the dell as primary resolves the issue for me , but it would not be the case for those whos only display is not supported in the profiles , (added the suported res of the monitor and such is auto detected if not and it will display its the other none auto detected settings that use the profiles that cause the font issues )

hope this helps others with the same issue, saving time in pinpointing the cause , and not spending hours randomly checking for drivers / libs / modules
i installed over 300 packages , for drivers/libs/modules , allong with development headders , using package search in yast , (3d3,vulkan,mesa,nvidia,opengl,directx, and other 3d realted searches ) and still have nouveau libs installed (nvidea driver installed over top of ) to name them all would take some doing itself , maybe if someone else gets the same issue and fixes the dpi fonts first then there going to be in a better position to find, if any, the offending required driver than the route i took

1 Like