Crash UE 5.4 project migration from 5.1

Hello everyone, I have a strange crash in 5.4. I have created in 5.1 a big map with world partition (around 1000km2) and when I try to convert my project into a 5.4 project, I have this crash message when it try to open the map, can you help me? Message: “Assertion failed: CellIndex < CellIndexMax [File:D:\build++UE5\Sync\Engine\Source\Runtime\Renderer\Private\SceneCulling\SceneCulling.h] [Line: 172]”

1 Like

I have the same problem…I could not find any solution so far. Epic, can you please take a look at this? It seems to be a engine bug…

I have tried many things but nothing is working, I realy NEED to convert my project in 5.4 and I need to do it NOW because I have to release before the end of the month…
Here is my log file:

[2024.06.10-13.46.01:968][290]LogWindows: Error: appError called: Assertion failed: CellIndex < CellIndexMax [File:D:\build++UE5\Sync\Engine\Source\Runtime\Renderer\Private\SceneCulling\SceneCulling.h] [Line: 172]

[2024.06.10-13.46.01:968][290]LogWindows: Windows GetLastError: L’opération a réussi. (0)
[2024.06.10-13.46.06:802][290]LogConsoleManager: Warning: Console variable ‘r.ShaderCompiler.JobCache’ used in the render thread. Rendering artifacts could happen. Use ECVF_RenderThreadSafe or don’t use in render thread.
[2024.06.10-13.46.06:802][290]LogThreadingWindows: Error: Runnable thread Foreground Worker #0 crashed.
[2024.06.10-13.46.06:804][290]LogWindows: Error: === Critical error: ===
[2024.06.10-13.46.06:804][290]LogWindows: Error:
[2024.06.10-13.46.06:804][290]LogWindows: Error: Assertion failed: CellIndex < CellIndexMax [File:D:\build++UE5\Sync\Engine\Source\Runtime\Renderer\Private\SceneCulling\SceneCulling.h] [Line: 172]
[2024.06.10-13.46.06:804][290]LogWindows: Error:
[2024.06.10-13.46.06:804][290]LogWindows: Error:
[2024.06.10-13.46.06:804][290]LogWindows: Error:
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ff9c160ecd0 UnrealEditor-Renderer.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ff9c1658fe1 UnrealEditor-Renderer.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ff9c15fe848 UnrealEditor-Renderer.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ff9c080ae3e UnrealEditor-Renderer.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ff9c07c4804 UnrealEditor-Renderer.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa267924c5 UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa267921ff UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa267ba155 UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa267823d0 UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa26987c93 UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa26dec93d UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffa26de02b7 UnrealEditor-Core.dll!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error: [Callstack] 0x00007ffb11897344 KERNEL32.DLL!UnknownFunction
[2024.06.10-13.46.06:804][290]LogWindows: Error:
[2024.06.10-13.46.06:804][290]LogWindows: Error: Crash in runnable thread Foreground Worker #0
[2024.06.10-13.46.06:816][290]LogExit: Executing StaticShutdownAfterError
[2024.06.10-13.46.06:884][290]LogWindows: FPlatformMisc::RequestExit(1, FRunnableThreadWin::GuardedRun.ExceptionHandler)
[2024.06.10-13.46.06:884][290]LogWindows: FPlatformMisc::RequestExitWithStatus(1, 3, FRunnableThreadWin::GuardedRun.ExceptionHandler)
[2024.06.10-13.46.06:884][290]LogCore: Engine exit requested (reason: Win RequestExit)

I have the same problem.
I think the bug is in the Landscape grass.
I tried creating a new project in UE 5.4.2.
I created a new map and a big new landscape.
I added a blank material, then I added a landscapeGrass node with a scalar 1 connected. The grass is a cube and density 1.
So far it works.
The crash occurs when I increase the “end cull distance” of the landscape grass type to something greater than 500000.

In my case Instanced foliage Grid Size is 50000, is that what you mean? Or do you speak about the culling distance into the foliage mode settings?

I’ve already reported the bug. I’ll post a question on the forum later to see if I get any answers.

Steps to Reproduce:

1- Create a new UE 5.4.2 project
2- Create a new level. Add lights.
3- Create a new Landscape (scale it to 3000 in x and y, since it happens at large distances)
4- Create a new material and apply it to the landscape
5- Add a LandscapeGrassOutput node
6- Create a Landscape Grass, apply it to the node and place a scalar with value 1
7- Place a cube as Grass Mesh, with density = 1. Everything else at default values.
8- Check that it works.
9- Increase the “Start Culling Distance” value to the maximum.
10- Increase the “End Culling Distance” value to the maximum. (I didn’t test it to see what the minimum value is, but it’s higher than 500000)
11- If the crash hasn’t happened yet, move the camera at high speed through the level.
12- The Editor closes.
13- The Crash Reporter appears with the following
Assertion failed: CellIndex < CellIndexMax [File:D:\build++UE5\Sync\Engine\Source\Runtime\Renderer\Private\SceneCulling\SceneCulling.h] [Line: 172]

Ok, so this is from the landscape material, the grass setting, I didn’t have the idea to look in it.
Thank you very much, I will try to do it tonight.

I have tried to change those settings but it’s still crashing.
Did you managed to make it work with this solution?

Not yet. If they answer me, I will tell you.

I have the same problem, has anyone been able to fix it?